issue installing opencv on Jetson (dependency problems)

Followed steps under:
Natively compiling the OpenCV library from source onboard the device
in http://elinux.org/Jetson/Installing_OpenCV

I run:

sudo add-apt-repository universe
sudo apt-get update
// And  finally
sudo apt-get install build-essential make cmake cmake-curses-gui g++

And i get:

WARNING: The following packages cannot be authenticated!
  emacsen-common cmake-data cmake cmake-curses-gui
Install these packages without verification [y/N]? y
Get:1 http://ports.ubuntu.com/ raring/main emacsen-common all 2.0.5 [17.3 kB]
Err http://ports.ubuntu.com/ raring/main cmake-data all 2.8.10.1-0ubuntu6
  404  Not Found [IP: 2001:67c:1360:8001::18 80]
Err http://ports.ubuntu.com/ raring/main cmake armhf 2.8.10.1-0ubuntu6
  404  Not Found [IP: 2001:67c:1360:8001::18 80]
Err http://ports.ubuntu.com/ raring/universe cmake-curses-gui armhf 2.8.10.1-0ubuntu6
  404  Not Found [IP: 2001:67c:1360:8001::18 80]
Fetched 17.3 kB in 0s (32.2 kB/s)
Failed to fetch http://ports.ubuntu.com/pool/main/c/cmake/cmake-data_2.8.10.1-0ubuntu6_all.deb  404  Not Found [IP: 2001:67c:1360:8001::18 80]
Failed to fetch http://ports.ubuntu.com/pool/main/c/cmake/cmake_2.8.10.1-0ubuntu6_armhf.deb  404  Not Found [IP: 2001:67c:1360:8001::18 80]
Failed to fetch http://ports.ubuntu.com/pool/universe/c/cmake/cmake-curses-gui_2.8.10.1-0ubuntu6_armhf.deb  404  Not Found [IP: 2001:67c:1360:8001::18 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

I got similar problems when attempting to install x11vnc previously ( 404 not found issue)…

Any guesses why the packages cannot be located? Workarounds?

I’m having to post this again because of a bug in the forum software. Seems that the slash character used when typing slash etc slash hosts breaks post when it tries to execute this as markup instead of display it.

What I see is all of your broken updates refer to the newer (and far less supported) IPv6 address for ports.ubuntu.com. If you do a host name lookup of ports.ubuntu.com it also provides this IPv4 dotted decimal address:

91.189.88.140

Try appending this to the end of your etc hosts file:

ports.ubuntu.com 91.189.88.140

The hope is that the system will attempt to ignore IPv6.

@linuxdev, thanks will give that a go in the morning.

so could this be that my local network infrastructure (router & ISP etc) does not fully support IPV6 yet?

Could it be an idea to disable it altogether and just run ipv4?
http://www.binarytides.com/disable-ipv6-ubuntu/

There are MANY network components (and their software) which do not properly support IPv6…to me IPv6 is still alpha test and useful only in private or well-funded environments with active administration.

As for disabling IPv6, only the DNS lookup is an issue. I do not know what is required for DNS/host name lookups to respond only with the IPv4 address (or to respond with IPv4 first and IPv6 only if there is no IPv4). If the IPv6 address fails, then trying to access such an address will fail regardless of whether the rest of the network has had IPv6 enabled or disabled.

Didn’t help unfortunately… Same 404 not found problem…

Packages could actually be missing, but everything I can see says the IPv6 address does not work.

Since it is still trying to use an IPv6 address which won’t work, you could temporarily replace “ports.ubuntu.com” in “/etc /apt /sources.list” (have to add spaces to keep forum formatting from breaking) with the IPv4 dotted decimal address (91.189.88.140). Save a copy of the original sources.list, and wherever you see an uncommented “ports.ubuntu.com” try substituting “91.189.88.140” instead.

Try disabling the IPv6 address of eth0:

http://www.tldp.org/HOWTO/Linux+IPv6-HOWTO/x1050.html

disabling IPV6 didn’t help.

However, changing the entries in sources did the trick, seems like I had some odd/incorrect entries.