Issue on accessing pwm pins in Jetson nano B01

Hardware : Jetson Nano B01
Jetpack : 4.3

I have downloaded the os from ( Release Support JetPack 4.3 · NVIDIA-AI-IOT/jetbot · GitHub).
I am trying to access the PWM pins from the B01 jetson nano using the official guide for configuring jetson nano 40 pins expansion header(Tegra Linux Driver)
after the congiguration part is finished, I tried to reboot Jetson nano and it gets struck in the Logo screen.

The result of uncompleted boot also happens when i tried this in a freshly installed jetson nano from this video: AI on the Jetson Nano LESSON 59: PWM on the GPIO Pins of the Jetson Nano - YouTube

How can i have access to the PWM pins in Jetson Nano b01

Hi @Shankaran,

You might not flash jetpack operating system properly. Does your system boot ? If it does not boot , you should flash the jetpack operating system by using sdkmanager.

For further information, please click below link.

@ozguryildiz

Thank you for the reply but I want to flash jetbot image in Jetson Nano B01 and flash that successfully but i need to configure the pwm pins how to do that?

It might be related with the free space. What do you get when you type “df -lh” ?

Additionally, below link can help you.
https://elinux.org/Jetson/PWM

@ozguryildiz @ozguryildiz Thanks I have try to access the pwm pins on jetson nano B01 based on the link as you mentioned above along with that I tried a configuring jetson nano 40 pin expansion header and the link is here(Tegra Linux Driver)

It throwed an error as attached screenshot

I have also attached a screenshot of free space as you mentioned above

Question:
How to overcome this error?
Is there any other solution accessing pwm pins on jetson nano B01 ?

The same issue discussed here. Actually it was known issue for JetPack 4.3.

They solved with this:

Otherwise you can update your JetPack version.

Regards

@mehmetdeniz Thanks for your reply I solved the error.
Now while trying to save and reboot,but it gets struck in nvidia logo on boot how to solve that ?

@mehmetdeniz please update me on this I need a solution to move on

You can check the logs from debug usb. Maybe your device will boot up from debug console.

Maybe you have not enough space to boot up your GUI. If you can log in from debug console can you check the free storage on your Jetson with “df -h” command?

@mehmetdeniz I already checked it the free space using the command df -h and attached the screenshot above