Issue Running isaac_ros_common Repository in Docker

I’m encountering an error when trying to set up the isaac_ros_common repository using Docker.
The problem occurs when executing the following command:

cd ${ISAAC_ROS_WS}/src/isaac_ros_common &&
./scripts/run_dev.sh

Error:

Running isaac_ros_dev-x86_64-container
docker: Error response from daemon: failed to create task for container: failed to create shim task: OCI runtime create failed: runc create failed: unable to start container process: error during container init: error mounting "/usr/lib/x86_64-linux-gnu/libEGL_nvidia.so.525.147.05" to rootfs at "/usr/lib/x86_64-linux-gnu/libEGL_nvidia.so.525.147.05": stat /usr/lib/x86_64-linux-gnu/libEGL_nvidia.so.525.147.05: no such file or directory: unknown.
~/workspaces/isaac_ros-dev/src/isaac_ros_common

My Docker works fine when I run the “hello-world” container using the following commands:

sudo service docker start
sudo docker run hello-world

I’ve tried reinstalling the nvidia container toolkit and tried removing the isaac ros image and rebuilding it.
Please help me find a solution

docker rmi isaac_ros_dev-x86_64

Hi @sweetyleah0

Looking at your error, your x86 machine doesn’t have all libraries installed.

Check if GPU libraries are installed, running:

nvidia-smi

and check if CUDA is installed with the correct version, running:

/usr/local/cuda/bin/nvcc --version

Isaac ROS 2.0 run with: CUDA 11.8+

All system requirements are available on this page: https://nvidia-isaac-ros.github.io/getting_started/index.html

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.