Issue runnung deepstream-app docker container (5.0 & 6.0) in RTX 3080 and A5000 laptop

Please provide complete information as applicable to your setup.

• Hardware Platform (RTX A5000 and 3080 GPU) in laptop
• DeepStream Version: 5.0 & 6.0

deepstream docker image version: nvcr.io/nvidia/deepstream:6.0-devel
CUDA: 11.4
cuDNN: 8.2+
TensorRT: 8.0.1
Driver: R470.63.01+
• NVIDIA GPU Driver Version (valid for GPU only): 470 & 510
• Issue Type( questions, new requirements, bugs):
when run docker run --gpus ‘"‘device=0’"’ -it --rm -v /tmp/.X11-unix:/tmp/.X11-unix -e DISPLAY=$DISPLAY…
gui x window is black and command line message shows "cuGraphicsGLRegisterBuffer failed with error(219) gst_eglglessink_cuda_init texture = 1"

this problem occurs in RTX A5000 and 3080 laptop. The OS is ubuntu 20.04.
there is no these issues in my personal computer and the graphic card is gtx 1660.

• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
reproduce the issue in RTX A5000 or RTX3080 laptop and OS is ubuntu 20.04,
nvidia driver is 470 or 510, install docker ce and nvidia-docker.
docker pull deepstream 5.0 or 6.0
when run deepstream-app, the x window is black.
command line message shows "cuGraphicsGLRegisterBuffer failed with error(219) gst_eglglessink_cuda_init texture = 1"
• Requirement details( This is for new requirement. Including the module name-for which plugin or for which sample application, the function description)

Did you run xhost + before run docker command?

yes I run “xhost +”, before run “docker run --gpus all…”

I follow the document of “DeepStream | NVIDIA NGC”,

Run the container

To run the container:

  1. Allow external applications to connect to the host’s X display:
xhost +
  1. Run the docker container (use the desired container tag in the command line below):
    If using docker (recommended):
docker run --gpus '"'device=0'"' -it --rm -v /tmp/.X11-unix:/tmp/.X11-unix -e DISPLAY=$DISPLAY -w /opt/nvidia/deepstream/deepstream-6.0 nvcr.io/nvidia/deepstream:6.0.1-[CONTAINER-TAG]

If using nvidia-docker (deprecated) based on a version of docker prior to 19.03:

nvidia-docker run -it --rm -v /tmp/.X11-unix:/tmp/.X11-unix -e DISPLAY=$DISPLAY -w /opt/nvidia/deepstream/deepstream-6.0  nvcr.io/nvidia/deepstream:6.0.1-[CONTAINER-TAG]

I can run the deepstream container well in PC which use gtx 1660 graphic card.

Did you use nvidia X server?
please follow this to check
https://download.nvidia.com/XFree86/Linux-x86_64/304.137/README/editxconfig.html

Thanks for your response.

But when I run “sudo nvidia-xconfig” and /etc/X11/xorg.conf can be prodused, my laptop cannot boot into desktop any more. I have to boot from ubuntu 20.04 usb drive and remove the /etc/X11/xorg.conf, then my notebook can boot into desktop.

Did your system failing to display a login session or something else?
check if this works
http://us.download.nvidia.com/XFree86/Linux-x86_64/510.73.05/README/commonproblems.html
I see a blank screen or an error message instead of a login screen or desktop session