Issue with Install of driver 515.65.: cannot insert module

Hoping for help to make sure new 1650 card is working.
installing driver 515.65 downloaded from NVidia driver download page fails in linux. compile works OK but cannot insert the module.
Need to confirm the card is supported for my kernel and/or test card and make sure no issues with the card.

The card is TUF-GTX1650-O4GD6-P-GAMING
MB = P7P55D-E
kernel = 4.4.14

error in nvidia-installer.log is
“Kernel module load error: Cannot allocate memory”
and further down in kernel messages
“NVRM: failed to initialize procfs”

I’ve ran the driver version 340 on this system for long time for my GeForce 210 card, no issues. Now adding the newer card having issues for the first time with NVidia drivers.

What is the minimum kernel version needed?
Is there anyway to test the card (in case it was damaged in shipment or something) to know if I need to return it?
Is this card just not supported by the driver?

Any help is appreciated.

Your card is supported by the 515 driver, the minimum kernel version is 3.10. The error message rather sounds like /proc isn’t mounted.

/proc is mounted (rw) as normal.
files as they should be.
Any particular /proc file that would be involved that might have an issue?

This is a system I’ve used heavily for a while, no major issues with it, only change is trying to update the NVidia driver.

Please run as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Last attempt I had tried was 495 version, I had tried multiple versions as part of troubleshooting, including some older ones after 515 had failed. To generate a bug report for the 515 version I re-ran (again) the 515 install and this time it worked as expected.
Not sure what is different but after a week if trying thigns I’ll take this as a win. I consider my issue resolved, with suspicion on what my PC did on the other attempts.