Issue with installing 4.2.1....... with Connect Tech Elory

I have a TX2 with a Connect Tech Elroy Carrier Board and although it took a few trying I finally got something when I tried to flash it. The image below is what it shows on the screen.

Any ideas? I tried booking it with the HDMI unplugged and no difference…

It looks like the rootfs is gone. Could you share the flash steps?

Are you using a usb drive or some external storage to flash?

Slight change, the above image is not happening anymore. It sat on this https://ibb.co/Lh8Kb8z for 20-30 minutes prior to me restarting it, then with the HDMI unplugged during the reboot nothing seems to change other then the time goes up (tried a few times) https://ibb.co/QYTKRr0 . Below is now I am installing, let me know if you see a problem.

I am guessing I am flashing it wrong, but let me know. I download the nvidia SDK. Let it download everything, but do not flash it using the SDK program (as instructed by connect tech’s readme).

I then follow the connect tech instructions of :

  1. Before Installing the BSP you will need to install Jetpack 4.2 on the x86
    host system using the Nvidia SDK Manager

    1. Copy the CTI-L4T-V###.tgz package into ~/nvidia/nvidia_sdk/JetPack_4.2_Linux_P3310/Linux_for_Tegra/

    2. Extract the BSP:

      tar -xzf CTI-L4T-V###.tgz

    (replacing ### with your file name)

    1. Change into the CTI-L4T directory:

      cd ./CTI-L4T

    2. Run the install script (as root or sudo) to automatically install
      the BSP files to the correct locations:

      sudo ./install.sh
      cd …

    3. The CTI-L4T BSP is now installed on the host system and it should now be
      able to flash the TX2/TX2i.

I have tried re-flashing it a few times, and a few reboots. Nothing really changes other than when I have the HDMI plugged in vs not, although it still Any ideas?

It looks to be a problem with 4.2.1 since I have just finished installing installing 4.2 on it and so far it seems to be working correctly. Not sure if 4.2 will work for my application yet but wanted to update things

Hi scbean,

Are you using some driver package from other vendor? The naming of “CTI-L4T” and some script like “./install.sh” is not from NVIDIA.

yes I am using connect tech’s BSP for the TX2 using the Elory, I am guessing using their driver package is needed? I also have an email out to Connect Tech to see what they say.

Hi scbean,

Our BSP is not yet compatible with Jetpack release 4.2.1, our software team is currently working on a new BSP which will be released soon, please check back on our support page. We are expecting an update the second week of August for this release.

Carter - Connect Tech Technical Support

Thank you for the update!