Issue with installing ros-humble-isaac-ros-yolov8 package on Jetson Orin Nano Developer Kit

I’m trying to install the ros-humble-isaac-ros-yolov8 package on my Jetson Orin Nano Developer Kit, following your guide here isaac_ros_yolov8 — isaac_ros_docs documentation

The issue is that this package seems to be missing. I’m having trouble with the installation. Any chance you can help out?

I’ve built a Docker container following the guide in isaac_ros_common. Here’s a screenshot of jtop:
image

error:

Hi @Nikolay196 ,

Have you tried to run before:

sudo apt update

and after

sudo apt-get install -y ros-humble-isaac-ros-yolov8

Yes, I tried, it didn’t help. Same error.
But there is a message that says that 300+ packages can be upgraded, is it worth doing it in a container? Won’t it break the dependencies?

As if this package doesn’t exist at all

$ sudo apt search ros-humble-isaac-ros-yolov8
Sorting... Done
Full Text Search... Done

@Raffaello Any other ideas why the ros-humble-isaac-ros-yolov8 package is missing?

Hi @Nikolay196 ,

Have you tried to update your docker? We released the new Isaac ROS 2.1 just last week with some bug fixes and improvements.

(I just tried it on Docker, and works)

Best,
Raffaello

Thanks it helped, I didn’t notice that there was an update

1 Like

No worries!

I’m here for that! :-)

1 Like