Issue with python setup

I follow document(Getting Started — Omniverse Robotics documentation) to setup python environment but compile failed with an error when running python setup.py install

Here is output:
running install
running bdist_egg
running egg_info
writing torch_wrap.egg-info/PKG-INFO
writing dependency_links to torch_wrap.egg-info/dependency_links.txt
writing top-level names to torch_wrap.egg-info/top_level.txt
reading manifest file ‘torch_wrap.egg-info/SOURCES.txt’
writing manifest file ‘torch_wrap.egg-info/SOURCES.txt’
installing library code to build/bdist.linux-x86_64/egg
running install_lib
running build_ext
building ‘torch_wrap’ extension
gcc -pthread -B /software/anaconda3/envs/isaac-sim/compiler_compat -Wl,–sysroot=/ -Wsign-compare -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-prototypes -fPIC -I/software/anaconda3/envs/isaac-sim/lib/python3.6/site-packages/torch/include -I/software/anaconda3/envs/isaac-sim/lib/python3.6/site-packages/torch/include/torch/csrc/api/include -I/software/anaconda3/envs/isaac-sim/lib/python3.6/site-packages/torch/include/TH -I/software/anaconda3/envs/isaac-sim/lib/python3.6/site-packages/torch/include/THC -I:/usr/local/cuda-11.1/include -I/software/anaconda3/envs/isaac-sim/include/python3.6m -c torch_wrap/Py_WrapTensor.cpp -o build/temp.linux-x86_64-3.6/torch_wrap/Py_WrapTensor.o -DTORCH_API_INCLUDE_EXTENSION_H -DTORCH_EXTENSION_NAME=torch_wrap -D_GLIBCXX_USE_CXX11_ABI=0 -std=c++11
cc1plus: warning: command line option ‘-Wstrict-prototypes’ is valid for C/ObjC but not for C++
creating build/lib.linux-x86_64-3.6
g++ -pthread -shared -B /software/anaconda3/envs/isaac-sim/compiler_compat -L/software/anaconda3/envs/isaac-sim/lib -Wl,-rpath=/software/anaconda3/envs/isaac-sim/lib -Wl,–no-as-needed -Wl,–sysroot=/ build/temp.linux-x86_64-3.6/torch_wrap/Py_WrapTensor.o -L:/usr/local/cuda-11.1/lib64 -lcudart -o build/lib.linux-x86_64-3.6/torch_wrap.cpython-36m-x86_64-linux-gnu.so
/software/anaconda3/envs/isaac-sim/compiler_compat/ld: cannot find -lcudart
collect2: error: ld returned 1 exit status
error: command ‘g++’ failed with exit status 1

Any suggestion?

Hi, please post the output of nvidia-smi. Also please check if libcudart.so exists in /usr/local/cuda-11.1/lib64.