Issue with Realsense + TX2

Hi,

I have tried to deploy realsense to TX2 developer board. I keep getting this error, can anyone please help me with it?


2019-08-03 23:44:10.365 WARNING packages/realsense/RealsenseCamera.cpp@37: Realsense recommended firmware version is 05.10.03.00, currently using firmware version 05.11.06.250
2019-08-03 23:44:11.206 ERROR engine/alice/component.cpp@61: Component ‘camera/realsense’ reported an error: RealSense error calling rs2_pipeline_start_with_config(pipe:0x7fa4065f20, config:0x7fa4067200): Couldn’t resolve requests
2019-08-03 23:44:11.206 ERROR engine/alice/backend/event_manager.cpp@40: Stopping node ‘camera’ because it reached status ‘FAILURE’


on the webserver, the realsense windows are all black. Looks like realsense camera was not turned on.

I am working with RealSense D435i on Jetson Nano. I have not tried Isaac SDK yet but I had to update the kernel of Ubuntu on Jetson Nano to get realsense-viewer work. I was wondering if it was possible to deploy apps that use RealSense cameras on Jetson boards with Isaac SDK without updating the kernel.

I used this guide to run realsense-viewer on Jetson Nano:

https://www.jetsonhacks.com/2019/05/16/jetson-nano-realsense-depth-camera/