Issue with SDK Manager: Apt repository check failure for libnpp-11-4

Hello NVIDIA community,

I’m encountering an issue with the NVIDIA SDK Manager while trying to install software packages on my system. Specifically, I’m facing an error related to the libnpp-11-4 package. Here’s the error message I’m getting:

SDK Manager is verifying system readiness to install.
Access to APT repository and ability to install Debian packages with it.
SDK Manager detected your system may not ready for installation, see specific errors below.
Once fixed, click ‘Retry’ to verify system readiness again.
‘Skip’ this process may result install installation failure.
Access to APT repository and ability to install Debian packages with it.: Apt repository check failure (1. sudo -S apt-get update && sudo -S apt-get check; 2. dpkg --audit).

E
:
The package libnpp-11-4 needs to be reinstalled, but I can’t find an archive for it

  1. I attempted to reinstall the libnpp-11-4 package using the command sudo apt-get install --reinstall libnpp-11-4, but it returned an error stating that it couldn’t find an archive for the package.
  2. I tried manually installing the package using the dpkg command, but encountered the error dpkg: error: cannot access archive '/path/to/libnpp-11-4.deb': No such file or directory.
  3. I also tried using the --fix-broken option with apt-get install, but it didn’t resolve the issue.

Could you please provide guidance on how to resolve this error and successfully install the libnpp-11-4 package? Any assistance would be greatly appreciated.

Thank you!

Hello,

Can you please tell me what system you are trying to install to?
I can then move this topic to the correct forum for you.

Thanks,
Tom

Hello. thank you for your response. I am trying to install the NVIDIA SDK Manager on a VMware virtual machine running Ubuntu 20.04. This installation is intended to support development for the Jetson AGX Orin platform. I am encountering issues specifically with the libnpp-11-4 package, which seems unavailable or inaccessible through the standard repositories and even when attempting manual installation.

Could you guide me on the correct approach to resolve this, or if there’s a specific forum or thread that I should follow for this issue?

Thanks again for your help.

Best regards,

Your topic will be best served in the Jetson category.

I will move this post over for visibility.

Cheers,
Tom

The VM is not supported, please find a host PC with Ubuntu OS to install the SDKM. Thanks

Can I not use VMware Workstation 16 to provide Ubuntu enviroment when I install the SDKM ? I have just windows computer in my local host OS.

Sorry to say that will have unknow problem as your met.
The native Ubuntu host PC is we suggested and verified.

can I achieve sdk manager Installation and flashing tools on Nvidia terminal with external monitor although I have windows OS laptop with Ubuntu enviroment VM?

Also if I connect Ubuntu host PC remotely from my windows OS, laptop, can I achieve to install SDK manager and use my device properly ?

  1. Don’t use a VM. Even if you get to fix this package issue, you will still have problems flashing Jeteson devices with a VM.
  2. Are you talking about packages on your x86 host PC or on your Jetson device? Alway put the full log, please.

Now I have 3 devices, windows OS laptop(I stopped to use VM as your suggested), Ubuntu OS computer and Nvidia jetson Agx Orin to work on researching for adapting our radar system processing from traditional DSP-based systems to leverage the power of NVIDIA GPUs. When I connected Ubuntu OS host PC remotely from my windows OS Laptop to set up right enviroment for flashing tools, can I ask when I connect Nvidia with USB A and USB C cable to my Ubuntu OS and left near to PC to achieve remote access and after set up SDK manager and write a command sdkmanager in my Ubuntu OS terminal and run the application,that stage I am downloading and installing tools for both Nvidia and my computer right ? so can I achieve this with connecting remotely from my windows OS laptop to Ubuntu OS laptop which is connected also with plugged in Nvidia Jetson AGX Orin device ,can I use my ubuntu computer and nvidia both of them together properly for my research with this remote access? I need to also use company computer to access our company data from such as GitHub.

Your comment is just too lengthy.
It doesn’t really matter whether you are using a Windows PC for remote control.
You just make sure both host components (on your Ubuntu PC) and JetPack SDK (on your Jetson device) are installed.

I am setting up the environment by remotely connecting my Windows laptop to the Ubuntu computer. My question is: When I connect the NVIDIA Jetson AGX Orin to the Ubuntu computer via a USB-A to USB-C cable and start the flashing process, do I need to install the SDK Manager tools on both my Ubuntu computer and the NVIDIA device, or does it happen automatically,when I open SDK manager ito start flashing from Ubuntu? Can I manage the SDK Manager installation and execute commands from my Windows laptop remotely?

I have made it clear here.
I don’t know why you keep getting stuck in remote control.
Anything like VNC, RDP, or even SSH will do it.

The point is really not remote control, but rather that you need a real Ubuntu PC instead of Windows/VM.

I have no idea what you are talking about here.

I am currently setting up my environment by remotely connecting my Windows laptop to an Ubuntu computer, which has an NVIDIA Jetson AGX Orin device connected via USB. My main question is about the installation and management of the SDK Manager. Specifically:

  1. Installation: Is the SDK Manager installed only on the Ubuntu machine, or is there any component of it that needs to be installed on the NVIDIA device itself during the flashing process?
  2. Management from Windows: Once the SDK Manager is set up on the Ubuntu computer, can I manage the flashing process and execute necessary commands from my remotely connected Windows laptop? This includes starting the SDK Manager, initiating the flashing process, and handling any required configurations.

On the Ubuntu PC.

I have said, any remote control software will do it.
Or you have any difficulty understanding it?

1 Like