Issue with TFTRT Imageclassification.py

I am not able to run imageclassification.py in tftrt in the latest version of the docker tensorflow-19.01-py3.

Traceback (most recent call last):
File “image_classification.py”, line 30, in
import official.resnet.imagenet_main
File “/workspace/models/official/resnet/imagenet_main.py”, line 27, in
from official.utils.flags import core as flags_core
File “/workspace/models/official/utils/flags/core.py”, line 30, in
from official.utils.flags import _base
File “/workspace/models/official/utils/flags/_base.py”, line 25, in
from official.utils.logs import hooks_helper
File “/workspace/models/official/utils/logs/hooks_helper.py”, line 29, in
from official.utils.logs import hooks
File “/workspace/models/official/utils/logs/hooks.py”, line 28, in
class ExamplesPerSecondHook(tf.estimator.SessionRunHook):
AttributeError: module ‘tensorflow.python.estimator.api.estimator’ has no attribute ‘SessionRunHook’

I am able to run the same code in 18.01-py2. What changes do i have to make in 19.01 and tf1.12.?

Hello,

which image_classification.py are you referencing?

Hi, I am referring to the code in the Tensorflow Container in NGC version 19.01.
Path for the code (inside the container)
/workspace/nvidia-examples/tensorrt/tftrt/examples/imageclassification/imageclassification.py

Thanks…

I have issue with identical traceback. Also tried few more versions of Tensorflow Container and on Xavier TX2 with jetpack version 4.1 with image_classification.py from https://docs.nvidia.com/deeplearning/dgx/integrate-tf-trt/index.html#image-class-usage. Would really appreciate any help with this issue as soon as possible.

Any update on this benchmark?

I solved it with the below resolution.