Issues Running DeepStream on WSL2 (Docker Container): usr/lib/x86_64-linux-gnu/libcuda.so.1: file exists\\\\n\\\"\"": unknown

So, i was try to run the deepstream container, having this error

docker run --gpus all -it --rm -v /tmp/.X11-unix:/tmp/.X11-unix -e DISPLAY=$DISPLAY -w /opt/nvidia/deepst
ream/deepstream-5.0 nvcr.io/nvidia/deepstream:5.0-dp-20.04-triton

docker: Error response from daemon: OCI runtime create failed: container_linux.go:349: starting container pr
ocess caused “process_linux.go:449: container init caused “process_linux.go:432: running prestart hook 0 ca
used \“error running hook: exit status 1, stdout: , stderr: nvidia-container-cli: mount error: file creati
on failed: /var/lib/docker/overlay2/35b2ed80985f81e2e2a6a0703b0a3b4c687b1e77fccba7d6605f77f402556078/merged/
usr/lib/x86_64-linux-gnu/libcuda.so.1: file exists\\n\”””: unknown.

I also tried to install the necessary drivers and tried to run a sample deepstream app, most of the time resulted in a segmentation fault, or this error:

/deepstream-image-decode-app …/…/…/…/samples/streams/sample_720p.mjpeg ─╯
WARNING: Overriding infer-config batch-size (2) with number of sources (1)
Now playing: …/…/…/…/samples/streams/sample_720p.mjpeg,
Running…
ERROR from element nvv4l2-decoder: Could not open device ‘/dev/nvhost-nvdec’ for reading and writing.
Error details: v4l2_calls.c(656): gst_v4l2_open (): /GstPipeline:dstest-image-decode-pipeline/GstBin:source-bin-00/nvv4l2decoder:nvv4l2-decoder:
system error: No such file or directory
Returned, stopping playback
Deleting pipeline

here is the driver and runtime details
╰─ deepstream-app --version-all ─╯
deepstream-app version 5.0.0
DeepStreamSDK 5.0.0
CUDA Driver Version: 11.1
CUDA Runtime Version: 10.2
TensorRT Version: 7.1
cuDNN Version: 8.0
libNVWarp360 Version: 2.0.1d3

and yes the sample docker container for tensorflow works as followed from this tutorial: https://docs.nvidia.com/cuda/wsl-user-guide/index.html

It is a bit hard to understand the exact setup and workloads you have run. Could you outline all the steps you performed in your WSL2 container so that we could try to repro it locally?

Also, since you added this:
-e DISPLAY=$DISPLAY

I would like to point out that there is currently no GUI support for WSL2.
Are you running XRDP session to the container?

I followed the exact guide from https://docs.nvidia.com/cuda/wsl-user-guide/index.html
i’ve installed the cuda toolkit apt-get install -y cuda-toolkit-11-0 and setup docker as per the instructions, i am able to run the example docker given in the tutorial, so seems like everything is working

GUI works fine, something i tried using XServer on Windows
No there is no XRDP session, its just plain container from nvcr.io/nvidia/deepstream:5.0-dp-20.04-triton

Windows 10 20152
Ubuntu 18.04 on WSL2 Kernel 4.19.121
(and specifically did not use the docker desktop for windows, rather i used the Docker-CE for Linux distributions as suggested in the tutorial)

but i feel like something is wrong with running deepstream container that causes this,

nvidia-container-cli: mount error: file creation failed: /var/lib/docker/overlay2/35b2ed80985f81e2e2a6a0703b0a3b4c687b1e77fccba7d6605f77f402556078/merged/
usr/lib/x86_64-linux-gnu/libcuda.so.1: file exists\\n\”””: unknown.

what could be the reason ?