issues to get egpu nvidia 1080 TI work on linux

hi i am trying to get nvidia 1080 TI to work with linux connected with RAZER CORE V2 to my mac book pro 2016 with touchbar thunderbolt 3 port for machine learning project . and i test it ppa nvidia driver and official driver get the same issues .

dmesg :

[ 5801.082222] NVRM: The NVIDIA GPU 0000:43:00.0
NVRM: (PCI ID: 10de:1b06) installed in this system has
NVRM: fallen off the bus and is not responding to commands.
[ 5801.082261] nvidia: probe of 0000:43:00.0 failed with error -1
[ 5801.082287] NVRM: The NVIDIA probe routine failed for 1 device(s).
[ 5801.082305] NVRM: None of the NVIDIA devices were initialized.
[ 5801.082736] nvidia-nvlink: Unregistered the Nvlink Core, major device number 507

po@po-MacBookPro:~$ sudo lspci -v | grep -i vga
[sudo] password for po:
pcilib: Cannot open /sys/bus/pci/devices/0000:44:00.0/config
lspci: Unable to read the standard configuration space header of device 0000:44:00.0
pcilib: Cannot open /sys/bus/pci/devices/0000:45:00.0/config
lspci: Unable to read the standard configuration space header of device 0000:45:00.0
pcilib: Cannot open /sys/bus/pci/devices/0000:46:00.0/config
lspci: Unable to read the standard configuration space header of device 0000:46:00.0
pcilib: Cannot open /sys/bus/pci/devices/0000:45:01.0/config
lspci: Unable to read the standard configuration space header of device 0000:45:01.0
pcilib: Cannot open /sys/bus/pci/devices/0000:47:00.0/config
lspci: Unable to read the standard configuration space header of device 0000:47:00.0
pcilib: Cannot open /sys/bus/pci/devices/0000:48:00.0/config
lspci: Unable to read the standard configuration space header of device 0000:48:00.0
pcilib: Cannot open /sys/bus/pci/devices/0000:45:02.0/config
lspci: Unable to read the standard configuration space header of device 0000:45:02.0
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Baffin [Radeon RX 460/560D / Pro 450/455/460/555/555X/560/560X] (rev c0) (prog-if 00 [VGA controller])
43:00.0 VGA compatible controller: NVIDIA Corporation GP102 [GeForce GTX 1080 Ti] (rev ff) (prog-if ff)

po@po-MacBookPro:~$ tbtadm topology
Controller 0
│ ├─ Details:
│ │ ├─ Name: Unknown device, Unknown vendor
│ │ └─ Security level: SL0 (none)
│ │
│ └─ Core, Razer
│ ├─ Details:
│ │ ├─ Route-string: 0-3
│ │ ├─ Authorized: Yes
│ │ ├─ In ACL: No
│ │ └─ UUID: 0033b17c-9271-2701-ffff-ffffffffffff
│ │
│ └─ Core, Razer
│ └─ Details:
│ ├─ Route-string: 0-103
│ ├─ Authorized: Yes
│ ├─ In ACL: No
│ └─ UUID: 0096097d-9271-2701-ffff-ffffffffffff
Controller 1
└─ Details:
├─ Name: Unknown device, Unknown vendor
└─ Security level: SL0 (none)

any help thanks .
nvidia-bug-report.log.gz (1.33 MB)