Issues with 410 nvidia and cuda installation


Every time I install nvidia driver 410 or 415, ubuntu gets stuck at “Started Gnome display manager” and the only solution I found to resolve this is by purging nvidia from the GRUB.
Now, I need CUDA 10.0. Every time I install CUDA 10.0 with nvidia driver other than 410 or 415(tried with 455, 450, 435), it automatically removes these drivers and switches to 410 open source driver, which again results in system getting stuck at “Started Gnome display manager”.


GPU Type: GP108 [GeForce GT 1030]
Nvidia Driver Version: 410
CUDA Version: 10.0
CUDNN Version: 7.4.2
Operating System + Version: Linux 18.04
Python Version (if applicable): 3.6
TensorFlow Version (if applicable): 1.14

Steps To Reproduce

Installing drivers -

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-driver-410
sudo reboot

This results in error like this -

Installing cuda -

sudo dpkg -i cuda-repo-ubuntu1804_10.0.130-1_amd64.deb
sudo apt-key adv --fetch-keys
sudo apt-get update
sudo apt-get install cuda

This is Cuda 10.0 removing driver 450

Things I have tried so far

Purging nvidia,cuda,cudnn,cublas etc and reinstalling everything.

Hi @minal,
Request you to raise the concern in the below forum


1 Like