Issues with CAD importer

I’d like to improve the tessellation quality of my CAD files but I run into issues on how to do this.

So here’s a .step files, a simple cylinder, exported from Fusion360 (Autodesk application). I tried to import this using the following settings.

And here’s how it displays as you can see the settings are not the ones I used during import and the cylinder doesn’t look smooth

Now when I try to update the Lin Delflection is doesn’t do anything, sometimes after doing this 10x it updates the file with a smooth and nice cylinder but it’s definitely not normal behaviour

I found a workaround for now is doing this:

and then

and now I have a nice smooth Cylinder but I really don’t understand what’s happening and why it works like this, if someone has some input on this that would be ace :) thanks

Hello @HansVanEven! I am going to direct your questions to the developer. I’ll post back when I have more information!

1 Like

Thanks Wendy

hello @HansVanEven,

Thank you for reporting this. Two questions:

  • Do you have to use the LOD widget to get the right tessellation and the Import Options are not applied first time you click “Import”?
  • Did you try the same Import Options with “Open in New Stage” unchecked? Is the result the same?

I’ve noted this as a bug, and will investigate more.

Cheers,
Ege

Hello Ege, thanks for chiming in.

The first time, I tried to adjust the import options, but indeed these weren’t always applied, it sometimes works, then today I found out that it works fine using the File > Import dialog

But in this case there aren’t any options it just worked.

cheers

Sorry to come back on this, seems that on another more complex model things don’t work that well, the File > Import didn’t gave me that good quality of import, hard to know how to use the settings, it’s a little too complicated for me as no way to revert to default settings once you made some changes, actually I’m complete lost on what’s the best file format to use from Fusion 360 into Create.