Issues with SDK Manager 0.9.8

Hi,

When I launch the sdkmanager and login, a popup suggests that a new version of the sdk manager is available and needs to be installed.

SDK Manager version 0.9.9 is now available (current version installed: 0.9.8).
 
This update is required for all DRIVE products installation.

Please click Update to continue.

But nothing happens on clicking update. Inspecting the log files suggests that the sdkmanager is getting a 404 error.

On the next screen, clicking on update leaving everything in default state leads to a screen with “OOPS Could not load the NVIDIA SDK details. There are no components available for installation”. Hitting “RETRY” doesn’t change anything.

What’s the best way to proceed from here? I get the following errors on the serial connection to the SoC -

HSM ERROR 244, CRITICAL_ERR_NVL_CAR
HSM ERROR 244, CRITICAL_ERR_NVL_CAR
HSM ERROR 244, CRITICAL_ERR_NVL_CAR
HSM ERROR 244, CRITICAL_ERR_NVL_CAR
HSM ERROR 244, CRITICAL_ERR_NVL_CAR
HSM ERROR 244, CRITICAL_ERR_NVL_CAR
HSM ERROR 244, CRITICAL_ERR_NVL_CAR
HSM ERROR 244, CRITICAL_ERR_NVL_CAR
HSM ERROR 244, CRITICAL_ERR_NVL_CAR
HSM ERROR 244, CRITICAL_ERR_NVL_CAR
HSM ERROR 244, CRITICAL_ERR_NVL_CAR
...

The above errors make it difficult to drive any evaluation of the system for our application.

Hi punitagrawal,

The new version of SDK manager is installed into the following path:
/opt/nvidia/sdkmanager

You can simply run to command sdkmanager without ./

Thanks!

The error fix will be in the upcoming release.

Hi carolyuu,

Thanks for responding to the query. There is no directory “/opt/nvidia”. As far as I can tell the update is not downloaded.

As mentioned in my original comment, looking at the logs in ~/.nvsdkm, the sdkmanager is getting a HTTP 404 response when trying to download the update. Let me know if you’d like to look at the logs - the “add attachment” button doesn’t seem to work either.

Thanks,
Punit

Thanks, vickyy. Hopefully, the issue with the sdkmanager can be ironed out before the next release becomes available.

One possible issue is that the approval for “DRIVE Early Access Developer Program” is pending. I can’t get to the SDK Manager user guide as well.

Can you look into approving the access? It might help fix the issue with the sdkmanager.

Yeah, I guess that may be due to without approval.
Could you contact our sales representative to get the early access approval first?

I’ve put in a request via https://www.nvidia.com/en-us/self-driving-cars/self-driving-contact/ but haven’t seen a response in ~week.

Any idea if something else is needed to get this moving?

Just to close out this query for others in similar situation, after approval for “Early Access Developer Program”, the error with sdkmanager goes away.

Thanks for you help.