It doesn't recognize the ac9260

I tried to use the ac9260 made by Intel.
However, the wifi interface does not show up.
Here is the command I ran.

$ uname -a
Linux chikage-jetson-nano 4.9.253-tegra #1 SMP PREEMPT Thu Oct 21 22:18:29 JST 2021 aarch64 aarch64 aarch64 GNU/Linux
$ lspci -nn | grep -i network
01:00.0 Network controller [0280]: Intel Corporation Wireless-AC 9260 [8086:2526] (rev 29)
$ iwconfig
lo        no wireless extensions.

rndis0    no wireless extensions.

usb0      no wireless extensions.

docker0   no wireless extensions.

l4tbr0    no wireless extensions.

eth0      no wireless extensions.

dummy0    no wireless extensions.
$ sudo lshw -C network
 *-network UNCLAIMED       
       description: Network controller
       product: Wireless-AC 9260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 29
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix cap_list
       configuration: latency=0
       resources: memory:13000000-13003fff
$ dmesg | grep -i firm
[    0.000000] psci: PSCIv1.0 detected in firmware.
[    1.650896] tegra-xusb 70090000.xusb: Firmware timestamp: 2020-07-31 09:33:12 UTC, Version: 50.26 release
[    4.755380] Bluetooth: hci0: Firmware revision 0.1 build 73 week 26 2018
$ rfkill list
0: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

I have run this Github.However, I can only use Bluetooth.
Is there a solution to get the Wi-Fi working?

Sorry for the late resposne, we will investigate to do the update soon.


thank you for your reply. I’m looking forward to hearing from you.

Please check other posts for this wifi card. We didn’t validate this card so cannot help.

Default driver also not includes this one.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.