It take too long time to(more than 1 minutes) boot from uefi to kernel

ls /dev,I can not find ttyACM devices

There should be error in your host side dmesg.

hi,the ufi boot stage,it takes about 27s,how should I decrease the boot time?

the uefi boot stage has so many “Deleting fragment fragment@” messages

Hi,

you can try to disable those drivers which are not needed in device tree .

I/TC: Primary CPU initializing
I/TC: WARNING: Test OEM keys are being used!
I/TC: This is only for TZ-SE testing and should NOT be used for a shipping product!
////////////////////////////////////////////////////////////////////////////////////////
how to close TZ-SE testing

I don’t think that really matters for your boot time.

PROGRESS CODE: V03040003 I0
add-symbol-file /home/csu/code/nvidia-uefi/Build/Jetson/DEBUG_GCC5/AARCH64/MdeModulePkg/Universal/SetupBrowserDxe/SetupBrowserDxe/DEBUG/SetupBrowser.dll 0x805303000
Loading driver at 0x00805302000 EntryPoint=0x00805314268 SetupBrowser.efi
PROGRESS CODE: V03040002 I0

PROGRESS CODE: V03040003 I0
add-symbol-file /home/csu/code/nvidia-uefi/Build/Jetson/DEBUG_GCC5/AARCH64/Silicon/NVIDIA/Drivers/BpmpScmi/BpmpScmiDxe/DEBUG/BpmpScmiDxe.dll 0x80546E000
Loading driver at 0x0080546D000 EntryPoint=0x0080547240C BpmpScmiDxe.efi
PROGRESS CODE: V03040002 I0

PROGRESS CODE: V03040003 I0
add-symbol-file /home/csu/code/nvidia-uefi/Build/Jetson/DEBUG_GCC5/AARCH64/Silicon/NVIDIA/Drivers/TegraCpuFreqDxe/TegraCpuFreqDxe/DEBUG/TegraCpuFreqDxe.dll 0x805368000
Loading driver at 0x00805367000 EntryPoint=0x0080536B6C4 TegraCpuFreqDxe.efi
PROGRESS CODE: V03040002 I0
////////////////////////////////////////////////////////////////////////////////////////////
so many message “add-symbol-file” like this,it is neccessary?how to close it?

any suggestions ?

  1. The uefi use the kernel dtb?
  2. Should I only modify the kernel dts file?
  3. need I modify other files?I have disabled some device nodes of the dts file and delete some overlay dts files,but uefi takes 20s also,just a few seconds less.

Check the post here.

BPFDTB_FILE=“tegra234-bpmp-3701-0000-3737-0000.dtb”;
DTB_FILE=“tegra234-p3701-0000-p3737-0000.dtb”;
TBCDTB_FILE=“tegra234-p3701-0000-p3737-0000.dtb”;
////////////////////////////////////////////////////////////////////////////////////////////
above, it is configure in jetson-agx-orin-devkit.conf ,I have upgraded the devkit by using flash.sh shell.I have not modify extlinux.conf. Is it right?

抱歉… 有點看不懂你想表示什麼.
extlinux.conf跟 jetson-agx-orin-devkit.conf沒有什麼關係…

Sorry, not quite sure what you want to ask here. How about you elaborate more about your question?
extlinux.conf has nothing to do with jetson-agx-orin-devkit.conf

I mean,I have not config TBCDTB_FILE=.I use r35.1 linux default config.Is it also Right?

You need to configure it so that your kernel dtb will be separate from your uefi dtb…

1.the uefi dtb should I use which device nodes?
2.If the kernel want to use like usb,can,the uefi dts can disabe the device node in the uefi dtb?

1.Can I disable all the device node if I do not want to use it int the boot stage,and enable the device node int the kernel dts?

605211] 3130000.serial: ttyTHS3 at MMIO 0x3130000 (irq = 57, base_baud = 0) is a TEGRA_UART
[ 9.685236] CPU:0, Error:cbb-fabric@0x13a00000, irq=21
[ 9.690526] **************************************
[ 9.695461] CPU:0, Error:cbb-fabric, Errmon:2
[ 9.699951] Error Code : TIMEOUT_ERR
/////////////////////////////////////////////////////////////////////////////////////////////////
I closed some device nodes in the tbcdtb,but the kernel produces exception int the kernel stage.

////////////////////////////////////////////////////////////////////////////////////////////////////
PROGRESS CODE: V03040003 I0
add-symbol-file /home/csu/code/nvidia-uefi/Build/Jetson/DEBUG_GCC5/AARCH64/NetworkPkg/Udp4Dxe/Udp4Dxe/DEBUG/Udp4Dxe.dll 0x8042A6000
Loading driver at 0x008042A5000 EntryPoint=0x008042AF194 Udp4Dxe.efi
PROGRESS CODE: V03040002 I0

///////////////////////////////////////////////////////////////////////////////////////
messages like above takes some times even if I close so many device nodes.The uefi can reduce some functions at the compile stage?

How do I modify the config options in the uefi code when compiling?
Looking forward to your reply.

Hi jasonGrave,

Actually, there is no 100% working method to decrease boot time now and we don’t guarantee UEFI would not crash if you just randomly remove things from UEFI.

If it crashed after your remove something, then it means you shouldn’t remove that.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.