I've got this brand new TX1 but don't see it in my USB tree

So I got this brand new TX1 a few years ago and I can’t wait to use it! 🤣😭. I picked it up a few years ago for a specific project that didn’t take off. I’m now coming back to it for a different one and trying to get it initialized.

I tried the SD card route, I actually had it up and running on Saturday temporarily, started updating everything, immediately after the updates, it wouldn’t come back up (no obvious errors, stopped at something like Starting journal or something along those lines – don’t have those logs anymore).

I thought I would take a different approach to getting it initialized and use the SDK Manager instead (as that seems to be recommended everywhere), so I fired up an Ubuntu 20 virtual machine and installed SDK Manager.

However, trying either USB-A or Micro USB, I can’t see it popping up in my USB tree.

I’m not sure what to try next, any suggestions?

Hi,

There are some mistakes.

  1. TX1 does not support such “sdcard route” as Jeston Nano and NX. It can boot from sdcard by some configuration but I don’t suggest someone who are new to this platform to try that.

  2. We don’t verify either 20.04 or VM for sdkmanager. The VM may be the cause of your flash failure.

Thanks @WayneWWW, I made some progress though probably still colouring outside the lines somewhat. I don’t have Ubuntu running on bare metal, so I’m running it in VirtualBox (which I understand isn’t supported). I moved back to Ubuntu 18, SDK Manager installed, was able to find and connect the TX1 on micro usb (had one of those damn micro usb power cables plugged in, after swapping I was connecting no problem.

Of no concern to this thread, I’m having issues with the TX1 disconnecting at some point during the flash, I’m working on trying to resolve that, but otherwise I’ve been able to go through all of the relevant SDK Manager steps at this point. No great log files, SDK Manager eventually just fails and I can see the TX1 is no longer connected, and for whatever reason my only recourse is to restart the VM entirely (can’t just disconnect, reconnect USB or restart the TX1). I’m flashing as we speak, I have lsusb running on a 10 second loop to see if I can get a time stamp that correlates with log files somewhere.

Also, as far as the SD card route, I did actually have this running at some point on the weekend, but I don’t know what it was that allowed me to get it to that point and I don’t know why I wasn’t able to get it running in subsequent tries after it stopped starting up. It seems like I should be able to just give it a bootable image, which is what worked that one time.

My suggestion is if you still cannot get usb connection problem resolved, then please try to find a ubuntu host instead of using VM.

We don’t guarantee the flash would work on VM. And there is no trick from our side to make it work.

However, maybe other users have experience on using VM to flash their board. You can also wait for their reply too.

And if you want to debug flash problem, dump the log from serial console would give you more info.

Serial console is the log from tx1 UART.

Amazing, thanks @WayneWWW! I expect that might be my only route at this point, I think I have everything else otherwise working.