J100 + TX2 + OV5647: can't get camera input

Hi everyone,

I’m a complete beginner in these environments trying to get camera input using a TX2 mounted on a J100. I’ve searched and tried everything I found for 2 days with no success, hence this post.

The camera I’m using is this one, connected to CSI-A:

I have tried using L4T revisions 28.1 and 28.2 and applied the Auvidea 1.5 firmware update for the J100.

/dev/video* is completely empty.

gst-launch-1.0 and nvgstcapture-1.0 always lead to ‘Socket read error. Camera Daemon stopped functioning’ messages.

I would really appreciate some help and please let me know if additional information is needed. As I said I’m starting on this field and I might be forgetting to provide some important details.

Thanks!

Hello lbcastro,

Have you find a solution now ?

I’m a beginner too in the TX2 environment and I’m interested in a fisheye camera, but I guess OV5647 is not working due to a lack of driver ?

As I understand, TX2 supports a restricted number of camera…
I have found a list of camera working on TX2 for sure here : https://elinux.org/Jetson/Cameras

I hope it helps a little. Let me know if you have found a solution :)

Hi,

Yes, that seems to be the problem, no carrier board manufacturer seems to support that camera sensor on the TX2.

I didn’t find a solution yet but I’m either switching cameras/carrier board or hire someone (like Ridgerun) to develop a custom driver for my current setup.

Thanks for the list!