Jarvis 1.3.0-beta fails on initial setup with error: "Convert_pytorch_to_trt failed"


Followed the documentation to download and install Jarvis on my Ubuntu system.
When executing ./jarvis_init.sh it downloads everything alright but in the end gives this error:
Exception: convert_pytorch_to_trt failed.


TensorRT Version:
GPU Type: 2070 Super
Nvidia Driver Version: 495.44
CUDA Version: 11.5
CUDNN Version:
Operating System + Version: Ubuntu 20.04.3 LTS

Relevant Files

Full error screenshot:

From what i have been reading on different forums, it seems that the GPU does not support Jarvis or TRT / CUDA is an old version. I have updated mine all to the latest version and i think my GPU is good enough (for bare minimum at least).

Tried to disable services (ASR / NLP / TTS) from config.sh file to have only one at a time but no success. Tried 2 times a clean install from everything still the same.

Steps to Reproduce

  1. Followed instruction from this NVIDIA DOC

  2. Then installed CLI following NGC CLI documentation for AMD64

  3. Then downloading Jarvis following NGC Jarvis Qucikstart documentation

Any help would be greatly appreaciated.


I solved my issue.
For anyone who might have similar issue in the future and find this post.
The problem is with the GPU.
I went to config.sh file and started only one service at a time. and run ./jarvis_init.sh to download only that model.
With RTX 2070 Super that i have, i can run with TTS and NLP acitvated no problem.
Seems like ASR is the ‘heaviest’ one because Server (./jarvis_start.sh) wont even start.

So the solution is to have the services active one at a time, if you have a GPU with less than 16GB of memory.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.