Jarvis docker mount failure

Hi , I am trying to run this docker on my NX with jetpack 4.5.
sudo docker run --gpus all -it --rm -v /home/dan/jspeech:/jspeech nvcr.io/nvidia/jarvis/jarvis-speech:1.0.0-b.1-servicemaker

I get the failure:
docker: Error response from daemon: OCI runtime create failed: container_linux.go:349: starting container process caused “process_linux.go:449: container init caused “process_linux.go:432: running prestart hook 0 caused \“error running hook: exit status 1, stdout: , stderr: exec command: [/usr/bin/nvidia-container-cli --load-kmods configure --ldconfig=@/sbin/ldconfig.real --device=all --compute --utility --video --require=cuda>=9.0 --pid=15292 /var/lib/docker/overlay2/87bafb2ec5b15a98aabefb3a10a62ab3360bdd7c33d33dd355be71cfa570b291/merged]\\nnvidia-container-cli: mount error: mount operation failed: /usr/src/tensorrt: no such file or directory\\n\”””: unknown.

Any help would be appreciated.
Thanks…Dan

Hi @Danieljyu2n ,

Currently Jetson NX is not supported in this beta release. Please refer to support matrix for all the supported GPUs.
https://docs.nvidia.com/deeplearning/jarvis/user-guide/docs/support-matrix.html

Thanks

Thank you for the quick reply. I now see that the 16 GB RAM requirements are beyond the NX specs. I would like to add conversational AI to my robot. Is there a set of ASR,NLU,TTS applications from Nvidia that are known to work with the NX or would an upgrade to the AGX module be required?
Daniel

Hi @Danieljyu2n,
This release does not support any Jetson. No arm/aarch64.
For now, will recommend you to try NeMo if he wants to deploy any such support on Jetson.
Please refer below link for more details related to NeMo:

Thanks

Hmm…Tried the link you recommended. The install procedures listed there failed. I don’t get that warm and fuzzy feeling that Nvidia actually has installed NeMo on the NX with Jetpack4.5…

Is there someone at Nvidia that works with the NX running Jetpack 4.5 that I can email and start a dialogue about getting Nemo installed? Thanks…Dan

I have the same problem. I am trying to run the NeMo docker container on the Jetson Xavier NX and I also get this “… mount operation failed: /usr/src/tensorrt:” error, when I try to run it.

What is the point referring to NeMo if this does not run either?

Very frustrating!
:-(

Hi,
Currently NeMo is not officially supported on Jetson platform.
It will be more convinient to use jetson-voice container on jetson, but NeMo on Desktop with descrete GPU, as there is already dockerized container with nemo for x86_64 [NGC]
also Jasper

You can refer to following topics in case you want to tryout NeMo on Jetson platform. I haven’t tried it personally (not guaranteed):

Thanks

@SunilJB
what is with jarvis support for Xavier AGX JP4.5?
not implemented yet?

More important question is why does Nvidia sell development boards and then not have the proper procedures in place to release software that has been tested to work? Mostly when I search the internet (and Nvidia) for information on frameworks like NeMo or Jarvis I get great marketing videos on the ease of development and all the greatness of containers. But none of it actually works. If I let my software guys get away with releasing software that didn’t work, I’d be out of business. Nvidia management does not take the NX or Nano development kits seriously. The people running that department should…NOT. This is not just a rant. Prove me wrong.

1 Like

I fully agree!
I’ve spent a lot of money to purchase a Jetson Xavier NX just to find out it is useless for speech recognition.
Lot’s of money wasted!
:-(

Jarvis 1.0 beta is the first public release of Jarvis and is formally targeted at datacenter GPUs. We appreciate the interest in deploying Conv AI applications on Jetson devices - we are working on it and hope to enable this in a future release.

Thanks

Hello SunilJB, I appreciate your feedback.
Which GPU would you recommend for Jarvis?