java application doesn't work right started by visual profiler on linux

I’m trying to profile a java application in which I am going to convert the underlying C library it calls to CUDA. I am on a desktop with Linux Mint sarah and I have CUDA 8 toolkit installed and running.

The problem is when the application runs in the profiling case, some of the dialogs do not draw correctly so I cannot start the workload. There is a configuration dialog that comes up and all the buttons and
text are blank.

In this case there is not yet CUDA, but even when I have the configuration settings to CPU only, this problem still occurs. I don’t have much time to write something to drive the library by a non-Java way, though I could do so as a last resort.

I’ve tried adding these options to nvvp.ini (after the java line):

as well as profiling CPU only.

Is there another suggestion? Is it possible to start profiling after my workload starts?

Hi, grafikarbeit

In my understanding, you want use Visual Profiler to do some CPU Profiling, right?

If so, you should create a new session and then enable “Profile execution on the CPU”.

Then if no CUDA in your sample, you will only find result under “CPU Details” view.

Thank you for the reply, Veraj. Yes, I had already seen and tried that with no success.

CPU Profiling is not my only purpose; as I convert the app to CUDA I would be trying to profile kernels as well.

So far as I can see, any option I try for profiling, either CPU Profiling and/or CUDA profiling, the Java application does not work correctly because some of its dialogs do not work.

I eventually focused just on trying to get some basic kernels to run in the C library called by Java. I kept encountering non-obvious crashes, so after some time, I have decided to abandon this exercise under Linux Mint,
and switch to Windows 10 64-bit, where I am much more familiar with the environment and tools and I won’t encounter these sort of oddities, I hope. I should be able to port it over after a while; I’m in the middle of backing up before I put on the Windows OS.