JAXI(AGXI) for making multi flash image


I’m trying to make an image for multi flash, but I have some error messages for executing nvmassflashgen.sh.

I have been in recovery mode, but the error messages showed there’s no Jetson device found.

But I can use the flash command to clone the system image from target and the target is in recovery mode.

The commands I used :

sudo ./nvmassflashgen.sh jetson-agx-xavier-industrial mmcblk0p1

sudo ./flash.sh -r -k APP -G Release.img jetson-agx-xavier-industrial mmcblk0p1

Attach is the log file
clone_rootfs_onyx.log (52.0 KB)

Thanks for help

hello zax0220jecht,

please review nvmassflashgen.sh, do you have below content included?

        "jetson-agx-xavier-industrial"          "2888"  "0008" \

please try adding board info to the command-line for creating the mass Flashing tarball,
for example,
$ sudo BOARDID=2888 BOARDSKU=0008 FAB=600 FUSELEVEL=fuselevel_production ./nvmassflashgen.sh jetson-agx-xavier-industrial mmcblk0p1

Hi Jerry,

The board info seems in the script already.

The script is in L4T downloaded by SDKM without any edition.

hello zax0220jecht,

could you please put JAGXi into forced-recovery mode, checking with $ lsusb, and please also share the usb-id for reference.
please also examine l4t_initrd_flash.sh, you may adding the ID to the script for testing.

Hi Jerry,

I’ve tried the commad and it worked.
$ sudo BOARDID=2888 BOARDSKU=0008 FAB=600 FUSELEVEL=fuselevel_production ./nvmassflashgen.sh jetson-agx-xavier-industrial mmcblk0p1
The command works and makes the mass Flashing tarball(mfi_xxx folder).

On the other hand, l4t_initrd_flash.sh already has the id (7819 and 7919)

Thanks for help.

furthermore, if you meet the failure shown… No devices to flash, you may also adding 7919 into nvmflash.sh to resolve that.

Hi Jerry,

I used the mass Flashing tarball with command nvmflash.sh and it showed no device to flash as you mentioned.
I add the ID 7919 to the script nvmflash.sh. and it worked,

thanks for great help.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.