Jeston Nano 4GB started freezing and rebooting by nvgstcapture-1.0 suddenly

Hello, I am a bit new at Jetson Nano and Ubuntu. I am using Jetson Nano 4GB model and Sony IMX 219 77 camera connected thorugh CSI connector. I was using it very properly for 1-2 months and weird things started few days ago.
Here is my detailed problem:
When I plug in my camera (which was working perfectly few days ago) in dev folder video0 appears and when I run the nvgstcapture-1.0 command Nano freezes and reboots. I have also tried usb camera and it did not see that at all.
Here is another thing, by time that problem starts my os (Ubuntu 18.04) starts to behave weird also. When I plug any external devices it lags and freezes. Even without any device, system program problem detected error pops up. I tired quite most of the solutions on the forum but nothing did work. I am using 5V4A power supply. Any advice will be aprreciated, thanks.

Hello @huseyinarslan.ceng ,

I hope you are doing well.

Please let me suggest you a couple debugging procedures.

  1. Check if the issue still happens if you capture with GStreamer.
    gst-launch-1.0 nvarguscamerasrc ! nvvidconv ! xvimagesink

  2. Check if the issue only happens when using arguscamera, by capturing with v4l2-ctl:
    2.1 Install v4l-utils
    sudo apt install v4l-utils
    2.2 Use v4l2-ctl to capture 1 raw frame
    v4l2-ctl -d /dev/video0 --set-fmt-video=width=1920,height=1080,pixelformat=RG10 --set-ctrl bypass_mode=0 --stream-mmap --stream-count=1 --stream-to=tets.raw

  3. I would also suggest connecting the board through UART to a computer and monitoring the output logs, if possible.

  4. Enable nvargus debug by running the following commands, into a separate console. Then start video capture using either nvgstcapture or GStreamer:

sudo su
service nvargus-daemon stop
export enableCamPclLogs=1
export enableCamScfLogs=1
  1. You could also try to re-flash the board and see if the issue disappears. Which would mean that the HW is all good and the issue was originated by some change in the software.

best regards,
Andres Campos
Embedded Software Engineer

Thanks for your time but I did all the things you write down before and after the reflash, they did not work. I am thinking that there might be a problem in the Nano.'s hardware. Is there any certain way to check that?

@huseyinarslan.ceng ,

Thanks for the update. I am very sorry to hear that you are still facing the same issue.

Unfortunately I am not a HW engineer, so my experience with debugging HW is very limited.

I would try to perform the following tests if possible:

  • Set the Jetson in 5W power mode: sudo nvpmodel -m 1
  • Use a different power supply.
  • Use a different sensor.

If you believe there is an issue with your board. Then this link might help you:

best regards,
Andres Campos
Embedded Software Engineer

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.