Jetbot Motors are not moving

Hi, I have been working with Jetbot. I’m using L298N motor driver along with PCA9685 servo driver.
The problem is, when I try to run the file on jupyter lab it runs the code without giving any error but the jetbot doesn’t move. I’ve tried changing the speed but still no success.

I have checked the batteries separately, they are working fine. My motor driver isn’t damaged either and I’m pretty sure I have made the right connections.

connections :
PCA9685 to Jetson Nano => GND->6 , SCL->5 , SDA->3 , VCC->1]

L298N to PCA9685 =>
Motor-A : ENA ->8 , IN1->9 , IN2 ----->10
Motor-B : ENB ->13 , IN3->11, IN4----->12

Are there any code changes that I need to make to make it work? Any help would be much appreciated.

Please check below topic to see if can help: How to use the jetbot with motor driver L298n - Jetson & Embedded Systems / Jetson TX2 - NVIDIA Developer Forums

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.