Jetpack 1.2 install

Good day all

I installed Jetpack 1.2 on my host Ubuntu (14.04 LTS) machine last night. Is it supposed to dump 10G into the root file system, or did I do something wrong? My installation was interrupted when I ran out of space in the root file system.

Also, my host system has CUDA 7 installed, will the installation of CUDA 6.5 from Jetpack interfere in some way with my previous CUDA 7 installation?

Much appreciated

Galto

So far as space is concerned, the rootfs is the size of the entire Jetson root file system install. It is actually more than this, as you start with the tar.bz2 and unpack it, so you have both the compressed archive and unpacked version; then there is the creation of a loopback mounted full file system, which copies this yet again, based on boot files and sample rootfs; finally, a sparse system (essentially compressed variant of loopback) is also created. File system use on host definitely exceeds rootfs size substantially.

Once sample rootfs is populated, the tar.bz2 archive could be deleted. Once the sparse file system has been created through the first flash, it should be possible to delete the uncompressed loopback image and tell it to re-use this sparse image for future flashes (assuming no parameters change). So long as you re-use the image you could even delete the content of the sample rootfs directory. For reference, system.img.raw is full-size uncompressed loopback mounted file, system.img is the sparse/compressed image which could be re-used.

I do not have an Ubuntu system so I do not use JetPack and do not know what issues there are for mixing CUDA 6.5/7.

Thanks for your reply linuxdev

What I actually meant to say was that after I run the Jetpack installer application on my host computer, basically following these instructions:

https://www.youtube.com/watch?v=RaBQbGfdup0 )

it basically fills up my entire system root folder (i.e. it installs all its stuff in my / folder on my linux box) until the install breaks because there is no more space left. I didn’t allocate more than 14G on / when I was setting up my system,

Was this really the intention of the installer or did I goof up somewhere?

JetPack installs more than the L4T flash setup. However, the L4T flash application itself can be fairly large. When installing just L4T flash software, without any of the eclipse or CUDA or other applications, there will be a subdirectory “Linux_for_Tegra”, and this subdirectory will contain all flash applications and data. Your host must have enough capacity to hold this without filling up. I’m going to say that prior to flash this will require about 9 GB on your host. During flash, it might temporarily require something like triple. This is in addition to what your operating system uses…if you have only 14 GB empty space, flash will fill the host prior to the flash completing.

If the files are being placed literally in the “/” folder…and if we are not talking about a parition, but an actual folder…then it was not unpacked correctly. There should be a subdirectory.

Hi linuxdev

thanks for your reply

yes I am talking about the root partition. As discussed in the link here:

https://help.ubuntu.com/community/DiskSpace

The minimum recommended size is 8GB. I gave mine 14GB when I installed Ubuntu. However, during the jetpack 1.2 installation the root partition got filled up completely, and then the installation failed (and as a result I now have unresolved dependencies).

So, since the Ubuntu documentation recommends a very conservative 15GB for the root partition, I am figuring something must have gone wrong during the jetpack installation causing it to dump all (or some generous portion of) its stuff in the root partition. I don’t think I should have made my root partition much larger (e.g. 30GB), or should I have? That’s what I am trying establish before I start all over again, probably starting with re-installing Ubuntu (and perhaps making my root partition 100GB just to be on the save side)

So I probably messed something up when going through the Jetpack installer queues - I just don’t recall what exactly…

The 8 GB minimum recommendation must be for a bare system, with almost nothing on it. I would definitely have a total partition size for operating system plus JetPack of more likely 75 GB…unless you are splitting it into many more partitions and you have something off to the side for JetPack…in which case you probably still need at least 30 GB. So 100 GB would indeed be a reasonable size for flash hosts. If you plan on developing software from the host you might want even more than 100 GB…eclipse and some of the IDE applications consume a very significant amount of disk.

Thanks for the insights linuxdev, much appreciated.

G