Jetpack 2.2, Tegra x1, opencv4tegra linking error

Hi guys, was trying to create and link a simplest possible program with opencv4tegra, but got a linking error with common opencv functions
here is my code

#include <opencv2/opencv.hpp>
#include <opencv2/highgui.hpp>

int main(int argc, char **argv)
    cv::Mat m = cv::imread("test.png");
    cv::imshow("image", m);
    return 0;

Here is how I compile and link:

g++ testOpencv.cpp -I/usr/include/ -L/usr/lib/ -lopencv_core -lopencv_highgui


g++ testOpencv.cpp -I/usr/include/ /usr/lib/ /usr/lib/

here is the error I get:

/tmp/ccSaN0S6.o: In function `main':
testOpencv.cpp:(.text+0x2a): undefined reference to `cv::imread(cv::String const&, int)'
testOpencv.cpp:(.text+0x66): undefined reference to `cv::imshow(cv::String const&, cv::_InputArray const&)'
/tmp/ccSaN0S6.o: In function `cv::String::String(char const*)':
testOpencv.cpp:(.text._ZN2cv6StringC2EPKc[_ZN2cv6StringC5EPKc]+0x2a): undefined reference to `cv::String::allocate(unsigned int)'
/tmp/ccSaN0S6.o: In function `cv::String::~String()':
testOpencv.cpp:(.text._ZN2cv6StringD2Ev[_ZN2cv6StringD5Ev]+0xa): undefined reference to `cv::String::deallocate()'
/tmp/ccSaN0S6.o: In function `cv::String::operator=(cv::String const&)':
testOpencv.cpp:(.text._ZN2cv6StringaSERKS0_[_ZN2cv6StringaSERKS0_]+0x18): undefined reference to `cv::String::deallocate()'
collect2: error: ld returned 1 exit status

I built this program with OpenCV3.1 and everything worked fine.
Does anyone has this too?

Hello, vixtor-qm:
Would you please update the Jetpack 2.3 and install related tools in Jetson TX1? I just tried and opencv programs can be compiled correctly and works well.