Jetpack 3.0 - JetsonTX2 - Corporate proxy

Hi,
I’m trying to setup Jetpack 3.0 on JetsonTX2 at work, but I’m behind a corporate proxy.
Do you know what is the best way to do this? I configured the proxy on bashrc on my linux workstation, but I’m stuck after flashing the JetsonTX2. Do you guys have any idea about what I should set on the JetsonTX2 to use the proxy?
Thanks,

Matteo

Hello,

You should set the environment variables on the Jetson TX2 also by configuring the proxy in its bashrc.
You may also try to configure this file: /etc/apt/apt.conf.d/01proxy
And add these lines :

Acquire::http::proxy "http://ID:PWD@PROXY_ADDR:PORT/";
Acquire::https::proxy "https://ID:PWD@PROXY_ADDR:PORT/";

To use firefox, you can also set the proxy in its advanced settings.

Are you connected directly to internet, or you are connected by your workstation ?
Do you have internet access on the Jetson ?

Good luck,

Yassine