JetPack 3.1 — L4T R28.1 released for Jetson TX1/TX2

Thank you @linuxdev that may actually be the issue. I am able to ping the TX1 from the VM but not vice versa. I expected this would not be an issue due to ‘one-way’ traffic from host to target.

I played around for a while to get the network settings to the point where I was able to see the TX1 (ping) and have internet connection too. I probably have to catch one of my old notebooks and install Ubuntu there - VMs seem to cause a lot of trouble here as I am not sure how to modifiy the network settings to get the TX to see the VM too.

I will try to attach a screenshot of my installation process, maybe you are able to confirm from that if the network is the actual problem here.

Edit: forgot to mention: yes, the TX1 is directly connected to the host PC/VM via patch cable and to internet via WLAN/Router, the host PC/VM connect to internet also via WLAN/Router

when you run Jetpack 3.1 ! you must not use “sudo”! this question is only found on the Jetpack 3.1!
in addition! TX1 need to connect network on line, at the same time, PC is on line!
I think that installing CUDA in the TX1, in fact, you download the CUDA in the TX1! next install。

if you run as root,then has error report,you should run as a user;

Thanks for pointing me in the right direction. Just managed to install everything without any trouble. I went through the whole process again incl. flashing OS but this time selected the WLAN network connection to move everything to the target. Took some time but it is working now.

Another question though: after installing everything and updating Ubuntu there are just 2.4G left of the 15G disk. I have seen all the install packages (.deb) lying around that fill up quite some space (cuda ~1.3G in multiple places). Can those files just be deleted or will they be needed again at some point? Probably missed the ‘deleted downloaded files’ check-box…

I do not know what can or cannot be deleted. If you flash on command line you can make maximum use via “sudo ./flash.sh -S 14580MiB jetson-tx1 mmcblk0p1”. The 14580MiB is “14580 * 1024 * 1024” bytes (15288238080).

A list of packages can be seen with “dpkg --list”

There are probably many packages you do not need. One thing to understand though is that when you install the CUDA repo package it gives apt access to the CUDA-related repository files. It is from this that actual CUDA (and many dependent packages) will be installed. What differs between this repo and most repos is that the repo is a “local repository” sitting somewhere in “/var” (versus a remote server over the internet). Regardless of whether the package is installed or not a version is in that repo. Removing the package removes it from somewhere like “/usr/local” (not sure where each package goes as installed…some probably add for example to “/usr/lib/”), but I believe the repo still exists in “/var”.

One thing which probably takes up a lot of unneeded space is if you installed the example programs. Perhaps you’ve also installed kernel source (kernel headers are much smaller…I’m thinking some people will install the actual kernel source).

A target location to look at and examine for possible delete is anything in “/usr/local”. You can see what package owns a file via:

dpkg -S /where/ever/that/file/is

If the file is not owned by a package, then you are probably safe to delete it without issues, but there are exceptions. Any file listed in “/etc/nv_tegra_release” is probably vital to being able to boot correctly. You’ll find losing (or having a non-NVIDIA version of) “/usr/lib/arm-linux-gnueabihf/tegra/libglx.so” is fatal to the graphical environment…this is one of the files listed in “/etc/nv_tegra_release”.

Thanks a lot! I will give it a try.
I guess I may move to a SD card or SSD at some point.

I am trying to install JetPack 3.1, but it fails download “Vision Work References” and “cuDNN Package”. please find the snapshot at this like:

  1. Dropbox - File Deleted
  2. Dropbox - File Deleted

Hi 16060073, do you still get the error when trying again or after a fresh JetPack download?
If so, please let us know the region you are downloading from so we can investigate it further.

Hi

I’ve been chasing problems on our Jetson TX1 builders running CI for various Linux distributions in chroots, and getting SIGILL in some configurations, since upgrading from R23 to R28 (i.e. Ubuntu 14.04 base to 16.04)

It appears the main culprit is missing kernel-level emulation for absent instructions, in the NVIDIA-compiled kernel.

ARMv8 is missing a few old ARM instructions present on older ARM silicon, and the Linux kernel supports emulating those instructions, to allow old apps to run - the four relevant kernel config options are:

CONFIG_ARMV8_DEPRECATED
CONFIG_SWP_EMULATION
CONFIG_CP15_BARRIER_EMULATION
CONFIG_SETEND_EMULATION

In our environment, at the very least, the first three are needed -
CONFIG_ARMV8_DEPRECATED is needed in order to enable any of the others, the 32-bit version of our software makes heavy use of CP15 memory barriers, and soft-float builds of Debian use SWP right in the package manager.

The kernel in R28.1 does not have SWP emulation enabled, so armel aptitude throws a SIGILL:

CONFIG_ARMV8_DEPRECATED=y

CONFIG_SWP_EMULATION is not set

CONFIG_CP15_BARRIER_EMULATION=y

CONFIG_SETEND_EMULATION is not set

Region: Pakistan
Jetson: TX2

Jetpack failed to download VisionWorks and cuDNN therefore, I downloaded both of these packages manually using links given here: https://gist.github.com/luongminh97/ad110be138d5917eee852d5645f9a717#file-repository-json-L1012
and placed them in the folder where JetPack downloads. On restart of JetPack, both packages are accepted by JetPack. But, JetPack gave error while installing on TX2 through micro-USB.

I have the issue with download of VisionWork and cuDNN in JetPack 3.1. I downloaded both manually then during flash it could not install cuDNN on TX2. However, a message asked to manually install cuDNN on TX2 to proceed flushing. I could see cuDNN get copied from Host to TX2.

Since you were able to obtain the packages, can you manually copy them to your TX2 and install them from the command line with dpkg or by double-clicking on them in file browser?

Hi Mohbat_Tharani, we have refreshed rthe CDN cache in your region, it should be working again now. Please let us know if you are still having trouble.

Hello my friends!

Have you solved the problem?

The problem where JetPack can’t download OpenCV or VisionWorks packages? The problem seems to have gone away since we refreshed the CDN caches in the region. Are you still seeing the behavior? If so, can you let us know the region you are accessing from, thanks.

Currently, I am busy with some other assignment till 10th of this month. I am going to give it a try by next week and then will surely update here.

Thanks you all for support.

OK, no problem, it should remain fixed now, but if you still have problems downloading/installing JetPack at that time, just let us know, thanks!

there is no /dev/video0 ? how can i fix it?
tx1 & Jetpack 3.1

Can you run nvgstcapture sample with a display attached to your Jetson? It should show a video with the camera video, that would confirm or disconfirm the camera is available. If the issue persists, please post a new topic on the TX1 board about it.

I cleaned my system and downloaded JetPack 3.1 run it. Previously, it was taking too long to download (10-20 kbps) headers however, headers do get downloaded at 200 kbps but still there is issue with downloading VisionWorks References, VisionWorks Plus SFM and cuDNN packages. I have downloaded these package from https://gist.github.com/luongminh97/ad110be138d5917eee852d5645f9a717] but problem us still there.
Please find the snapshots here: Dropbox - File Deleted