JetPack 3.2 — L4T R28.2 Developer Preview for Jetson TX2

We’re pleased to announce that a developer preview release of JetPack 3.2 is now available for Jetson TX2!

Highlights include support for TensorFlow models in TensorRT 3.0, up to 15% perf/W improvement for DL applications, out-of-the-box kernel support for Docker, and support for Ubuntu 16.04 on your host PC (Ubuntu 14.04 on your host PC will also work, except cross-development packages for OpenCV and VisionWorks will be unavailable on that host PC). The preview is only for TX2. For more info, please view the full Release Notes.

JetPack 3.2 components:

  • L4T R28.2
  • CUDA 9.0
  • cuDNN 7.0.5 RC
  • TensorRT 3.0 RC2
  • OpenCV 3.3.1
  • VisionWorks 1.6

Release Notes…
Download JetPack…
Software Overview…
28.2 Release Page…
Archive Page…

It is exciting to see there’s finally one OpenCV people have to worry about. Looking forward installing and testing on TX1. :)

Hi,I downloaded JetPack 3.2 DP, but when it began to install, it seems to install the 3.1 version of JetPack, Is there something to config? (my OS is ubuntu 16.04)

I’m new with tx2 so i need to ask
If i install jetpack 3.2 is that mean that i installed opencv with it and there is no need to install it alone again

I’m a TX1 user so cannot try JetPack 3.2 DP :(

  1. Will the JetPack 3.2 GA release support TX1 ?
  2. When will it come ?


Hi kenzo.naghisa, to answer your questions:

  1. Yes, JetPack 3.2 GA release will support TX1.
  2. It’s undetermined yet at this time the date of release.

If you would like, you could use JetPack 3.2 Developer Preview to download the packages (or see here) and manually install them to TX1.

Hi ths937, are you using TX2 or TX1? If TX2, can you delete the files created by JetPack (or move JetPack to a new directory) and try again?

Hi Fo2sh44, JetPack installs packages for OpenCV on both the host (cross-development) and the target Jetson. Unless disabled, it updates the host and installs OpenCV on Jetson. Running JetPack with the default options will flash your Jetson with the latest L4T and default vanilla Ubuntu image.

Hi dusty_nv Thanks for your reply!,I’m using TX2,and I tried several times, but it only get 3.1 version to install. I also checked the manifest.json and repository.json, and do not find anything about the 3.2 verison related file(cuda is 8.0.84 .etc). btw, my OS is ubuntu 16.04.03 Gnome,It has some effect on this?


It may be related to which country you are downloading from, but I’ve just downloaded it from Europe and installed without problem:

head -1 /etc/nv_tegra_release 
# R28 (release), REVISION: 2.0, GCID: 10136452, BOARD: t186ref, EABI: aarch64, DATE: Fri Dec  1 14:20:33 UTC 2017

Did you download and install from a fresh directory or reused a previous JetPack directory?
I have created a JetPack-3.2 folder at the same level as, cd into this folder and there run …/ (sorry not sure about its name, I’m on TX2, no longer on host).

Just looked at opencv3.3.1 included, and feel very disappointed…no CUDA nor gstreamer support. I cannot understand how nobody in nvidia is able to generate a better config for this:

General configuration for OpenCV 3.3.1 =====================================
  Version control:               3.3.1

    Timestamp:                   2017-11-13T07:18:22Z
    Host:                        Linux 4.4.38-tegra aarch64
    CMake generator:             Unix Makefiles
    CMake build tool:            /usr/bin/make
    Configuration:               Release

  CPU/HW features:
    Baseline:                    NEON FP16
      required:                  NEON
      disabled:                  VFPV3

    Built as dynamic libs?:      YES
    C++ Compiler:                /usr/bin/c++  (ver 5.4.0)
    C++ flags (Release):         -D _GLIBCXX_USE_CXX11_ABI=0   -fsigned-char -W -Wall -Werror=return-type -Werror=non-virtual-dtor -Werror=address -Werror=sequence-point -Wformat -Werror=format-security -Wmissing-declarations -Wundef -Winit-self -Wpointer-arith -Wshadow -Wsign-promo -Wuninitialized -Winit-self -Wno-narrowing -Wno-delete-non-virtual-dtor -Wno-comment -fdiagnostics-show-option -pthread -fomit-frame-pointer -ffunction-sections    -fvisibility=hidden -fvisibility-inlines-hidden -O3 -DNDEBUG  -DNDEBUG
    C++ flags (Debug):           -D _GLIBCXX_USE_CXX11_ABI=0   -fsigned-char -W -Wall -Werror=return-type -Werror=non-virtual-dtor -Werror=address -Werror=sequence-point -Wformat -Werror=format-security -Wmissing-declarations -Wundef -Winit-self -Wpointer-arith -Wshadow -Wsign-promo -Wuninitialized -Winit-self -Wno-narrowing -Wno-delete-non-virtual-dtor -Wno-comment -fdiagnostics-show-option -pthread -fomit-frame-pointer -ffunction-sections    -fvisibility=hidden -fvisibility-inlines-hidden -g  -O0 -DDEBUG -D_DEBUG
    C Compiler:                  /usr/bin/cc
    C flags (Release):           -fsigned-char -W -Wall -Werror=return-type -Werror=non-virtual-dtor -Werror=address -Werror=sequence-point -Wformat -Werror=format-security -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wundef -Winit-self -Wpointer-arith -Wshadow -Wuninitialized -Winit-self -Wno-narrowing -Wno-comment -fdiagnostics-show-option -pthread -fomit-frame-pointer -ffunction-sections    -fvisibility=hidden -O3 -DNDEBUG  -DNDEBUG
    C flags (Debug):             -fsigned-char -W -Wall -Werror=return-type -Werror=non-virtual-dtor -Werror=address -Werror=sequence-point -Wformat -Werror=format-security -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wundef -Winit-self -Wpointer-arith -Wshadow -Wuninitialized -Winit-self -Wno-narrowing -Wno-comment -fdiagnostics-show-option -pthread -fomit-frame-pointer -ffunction-sections    -fvisibility=hidden -g  -O0 -DDEBUG -D_DEBUG
    Linker flags (Release):      
    Linker flags (Debug):        
    ccache:                      NO
    Precompiled headers:         NO
    Extra dependencies:          dl m pthread rt /usr/lib/aarch64-linux-gnu/
    3rdparty dependencies:

  OpenCV modules:
    To be built:                 core flann imgproc ml objdetect photo video dnn imgcodecs shape videoio highgui superres ts features2d calib3d stitching videostab python2
    Disabled:                    js world
    Disabled by dependency:      -
    Unavailable:                 cudaarithm cudabgsegm cudacodec cudafeatures2d cudafilters cudaimgproc cudalegacy cudaobjdetect cudaoptflow cudastereo cudawarping cudev java python3 viz

    QT:                          NO
    GTK+ 2.x:                    YES (ver 2.24.30)
    GThread :                    YES (ver 2.48.2)
    GtkGlExt:                    NO
    OpenGL support:              NO
    VTK support:                 NO

  Media I/O: 
    ZLib:                        /usr/lib/aarch64-linux-gnu/ (ver 1.2.8)
    JPEG:                        /usr/lib/aarch64-linux-gnu/ (ver )
    WEBP:                        build (ver encoder: 0x020e)
    PNG:                         /usr/lib/aarch64-linux-gnu/ (ver 1.2.54)
    TIFF:                        /usr/lib/aarch64-linux-gnu/ (ver 42 - 4.0.6)
    JPEG 2000:                   /usr/lib/aarch64-linux-gnu/ (ver 1.900.1)
    OpenEXR:                     NO
    GDAL:                        NO
    GDCM:                        NO

  Video I/O:
    DC1394 1.x:                  NO
    DC1394 2.x:                  NO
    FFMPEG:                      YES
      avcodec:                   YES (ver 56.60.100)
      avformat:                  YES (ver 56.40.101)
      avutil:                    YES (ver 54.31.100)
      swscale:                   YES (ver 3.1.101)
      avresample:                NO
<b>    GStreamer:                   NO</b>
    OpenNI:                      NO
    OpenNI PrimeSensor Modules:  NO
    OpenNI2:                     NO
    PvAPI:                       NO
    GigEVisionSDK:               NO
    Aravis SDK:                  NO
    UniCap:                      NO
    UniCap ucil:                 NO
    V4L/V4L2:                    NO/YES
    XIMEA:                       NO
    Xine:                        NO
    Intel Media SDK:             NO
    gPhoto2:                     NO

  Parallel framework:            TBB (ver 4.4 interface 9002)

  Trace:                         YES ()

  Other third-party libraries:
    Use Intel IPP:               NO
    Use Intel IPP IW:            NO
    Use VA:                      NO
    Use Intel VA-API/OpenCL:     NO
    Use Lapack:                  NO
    Use Eigen:                   YES (ver 3.2.92)
<b>    Use Cuda:                    NO</b>
    Use OpenCL:                  NO
    Use OpenVX:                  NO
    Use custom HAL:              YES (carotene (ver 0.0.1))

  Python 2:
    Interpreter:                 /usr/bin/python2.7 (ver 2.7.12)
    Libraries:                   /usr/lib/aarch64-linux-gnu/ (ver 2.7.12)
    numpy:                       /usr/lib/python2.7/dist-packages/numpy/core/include (ver 1.11.0)
    packages path:               lib/python2.7/dist-packages

  Python 3:
    Interpreter:                 /usr/bin/python3 (ver 3.5.1)

  Python (for build):            /usr/bin/python2.7

    ant:                         NO
    JNI:                         NO
    Java wrappers:               NO
    Java tests:                  NO

  Matlab:                        Matlab not found or implicitly disabled

    Doxygen:                     NO

  Tests and samples:
    Tests:                       YES
    Performance tests:           YES
    C/C++ Examples:              YES

  Install path:                  /usr

  cvconfig.h is in:              /home/nvidia/build-opencv/build

There are some issues with OpenCV and CUDA9, hence it isn’t enabled, however you are welcome to build from source.


Thanks for your comment. I’m currently rebuilding from source for CUDA-9.0 and gstreamer support. I’ll let you know if I run into troubles.

I also notice the dt patch for overlay 2 is not included in the RC. Is there also some test failing with this ?

Could you please also comment some new fields such as fg/bg (foreground/background ?) from updated command tegrastats ?

RAM 1933/7851MB (lfb 2x4MB) CPU [0%@2035,0%@2034,0%@2035,0%@2035,0%@2034,0%@2035] EMC_FREQ 1%@1866 GR3D_FREQ 0%@1300 APE 150 MTS fg 43% bg 45% BCPU@32C MCPU@32C GPU@38C PLL@32C AO@29.5C Tboard@27C Tdiode@26.75C PMIC@100C thermal@30.7C VDD_IN 6372/6372 VDD_CPU 1983/1983 VDD_GPU 229/229 VDD_SOC 992/992 VDD_WIFI 344/344 VDD_DDR 1282/1282

How about TK1? Will TK1 be supported in JetPack 3.2 GA release?

Hi k_sze, TK1 is not receiving new updates with JetPack 3.2, TK1’s current release is L4T R21.6 LTS (long-term support).

What I mean to ask is whether I will be able to use JetPack 3.2 GA to flash/provision TK1, and move to use Ubuntu 16.04 on the host PC. I don’t mind if it will still be L4T 21.6 for TK1.

Hi k_sze, you can use JetPack 3.1 application to flash TK1, it will just use L4T R21.6.

If you have issue with Ubuntu version, you can disable cross-development packages for OpenCV and Visionworks (for host).

Thanks I finally get host to install by enter the unpack direction and run “./Launcher -q

I followed the instructions on the following webpage to flash Jetpack 3.2 DP on TX2

/etc/nv_tegra_release seems to show the R28 release :

R28 (release), REVISION: 2.0, GCID: 10136452, BOARD: t186ref, EABI: aarch64, DATE: Fri Dec 1 14:20:33 UTC 2017

However, it is unclear to me where the <JetPack_Install_Dir> is on TX2.

I suspect that the installer did not actually install all the components in step 14 after rebooting the system. If it is the case, how do I resume from that point ?