JetPack 3.3 fails to install uff package

I have Jetson TX2 platform with JetPack 3.3.
I tried to install uff package with following commands
sudo apt-get update
sudo apt-get install uff-converter-tf

Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package uff-converter-tf

In previous version (JetPack 3.2) I have successfully installed uff package by following command but
this compatible for TensorRT-3.

sudo pip3 install TensorRT-3.0.4/uff/uff-0.2.0-py2.py3-none-any.whl

Is there any way to install uff package on Jetson TX2 with JetPack 3.3?


same thing over here. I can’t parse my TF model for Jetson TX2 because uff.from_tensorflow is cannot be imported?


Uff library is included in our x86 package. Please download it on our website:

And install via these commands:

$ tar -xzf TensorRT-
$ sudo pip install TensorRT-



I’m having the same problem. I’m working on Jetson Tx2, Jetpack 3.3 and I need uff converter C++ API. I have tried to use tensorrt_4.0.2.0-1+cuda9.0_arm64.deb which is downloaded in Jetpack installation but it is not solved. How can be installed?


The UFF workflow consists of two components.

  1. UFF exporter (Python, distributed for desktop only)
  2. UFF parser (C++, distributed for desktop and Jetson)

However, because the exporter is a pure python package, you can actually install the UFF package distributed for desktop on the Jetson. This is done as mentioned above.