JetPack 3.3 - L4T-3.3-linux-x64 Installation

Hi,

I need your help. I’m trying to install “JetPack-L4T-3.3-linux-x64_b39.run” file on Ubuntu 16.04 host machine but the Component Manager is empty although I have an Internet connection.

When I’m trying to apply the same steps for the JetPack 3.2 installer, I manage to install. However, for JetPack 3.3 installer, it does not work.

Host platform: Ubuntu 16.04 x64
Target platform: Jetson TX1
JetPack 3.3

Thanks!

Is there a proxy or firewall? Both are common at businesses.

Some areas of the world will also filter.

One trick which can get in the way is if you run two versions of JetPack from the same directory. Be sure to start with a clean JetPack directory.

I am connected from Turkey.

I also tried to install JetPack 3.3 from a different directory than JetPack 3.2 and it didn’t work either.

Thanks

One thing you can be sure of is that the empty component list is due to the network not being able to retrieve the manifest. Different regions of the world might route differently, and thus look for a different server, but I have no idea of what areas differ. If you have a proxy or firewall, then I’d start by seeing if this is blocking you. Often businesses have a firewall and/or proxy.

If not a local network issue, then perhaps someone who knows what server JetPack3.3 uses when in Turkey might comment on the status of that server (e.g., if it is up and working or not, and which server the end user can ping to see if it is reachable).

I solved the issue. This was due to proxy settings.

Thanks

Hi Deniz_92,

Proxy setting is supported via environment variable. Please run JetPack with following method:

  • Run in terminal http_proxy=http://username:password@proxy_ip:proxy_port ./JetPack-L4T-3.3-linux-x64_b{build_number}.run
  • Any special characters in the user name or password should be URL encoded. There is a website to encode the characters: https://opinionatedgeek.com/Codecs/UrlEncoder

Please let us know if you still face issues.

Hi.
Does not work, and only with this version in ubuntu 18.04

It is unclear what is failing…more details would help. This thread’s original issue seems to have revolved around network issues, but you might be running into something completely unrelated. You could attach a log. If you hover your mouse over the quote icon in the upper right of one of your existing posts, then other icons will show up…the one which looks like a paper clip is for attaching files.