JetPack 3.3 not working

Hi,

I am trying to use JetPack 3.3 and the installation won’t proceed.
After clicking Next in the Components Manager window, the buttons gray out but then it stops without any error messages. This happens to any action that I want to do in the installation.

I have already tried reinstalling JetPack but it still happens. Has anyone encountered this before?

Hi luis.buno,

I tried install JetPack-3.3 today, no issue.
Could you remove all files and download again?

Please let us know if your components manager still not working.
Thanks!

Hi carolyuu,

The same thing happened even if I removed the JetPack3.3 files and download and reinstalled it again.

The other observation that I noticed is that after selecting the development enviroment (TX2), there is no pop-up window appearing to enter my sudo password. It just goes directly to Components Manager window.

Hi luis.buno,

What is your host computer? Ubuntu 16.04?
Please check install guide from: https://docs.nvidia.com/jetpack-l4t/index.html#jetpack/4.1ea/install.htm%3FTocPath%3D_____3

Hi carolyuu,

Yes, our host computer is 64-bit Ubuntu 16.04 LTS. I have used this host computer before. I think the JetPack that worked previously was JetPack 3.1.

I have followed the steps in the install guide and I’m still stuck in the Components Manager window.

Hi luis.buno,

Could you help try to install JetPack-3.1? Is this issue only happen on JetPack-3.3?
Please also check with your network. Thanks!

Hi carolyuu,

Sorry for the delayed response. I haven’t tried using JetPack-3.1 again.

But I’m thinking now that our network is the problem. Our company firewall might be blocking sites being accessed by the JetPack installer. Can you specify which sites are being accessed by the installer?

Thanks!

Hi luis.buno,

Can you install JetPack-3.3 now?
Which components package you want to install? or just want to flash release image?

Thanks!

Hi,

I have same issue.

JetPack 3.1 is okay to download all in the JetPack L4T Component Manager window.

However, JetPack-L4T-3.3-linux-x64_b39 does not… even though I tried multiple times…

Is it common issue to the JetPack 3.3 ? Otherwise, how can I upgrade from JetPack 3.1 to 3.3 after completing installation of 3.1 version?

Thanks,

I have the same problem with the JetPack 3.3 and my machine directly connect to the internet with no firewall. but for me, JetPack 3.0 actually works to get all the package list.

Hi Luis, kyumanlee84logs/jetpack_debug.log, walkingskeleton,

Is the issue solved now? If not, can you please provide the following files?

  1. <JetPack_3.3_Install_Dir>/_installer/logs/jetpack_debug.log
  2. <JetPack_3.3_Install_Dir>/jetpack_download/repository.json

kyumanlee84, walkingskeleton,
Do you have the exactly same issue as Luis? i.e., all buttons gray out and cannot download anything?

Hi Edward, I tried several different machines, and confirm that Jetpack3.3 fresh install doesn’t work and there’s no details in jetpack_debug.log other than finished create_workspace and there’s no jetpack_download folder been created at all. I was posting in the jetpack 3.3 release announcement post, and my solution was to download jetpack 3.0, which works for me, and let it finish all the installation by downloading all the packages, then I tried to start 3.1, 3.2.1, all seem to be able to load the package lists, then I started the 3.3 again, and this time it was able to see the package list and I was successful on downloading, installing and flashing the TX2 board, which also resolved my cuda library problem.

Hi Edward,

JetPack 3.3 is still not working. Attached are the files that you asked.
jetpack_debug.log (2.96 KB)
repository.json.txt (319 KB)

Thanks luis.

I checked the logs. And need your further help to check.
Can you please run following command in a terminal window to see if there is any error?

DEBUG=1 /home/glenn/JetPack3_3/_installer/InstallUtil setup /home/glenn/JetPack3_3/ 14686

Thanks walkingskeleton.
Looks like you have a different issue from what luis met. The contents of jetpack_debug.log on your machine might be corrupted by other versions of JetPack install. Usually JetPack is installed in a clean folder with the default download folder and installation folder. I’m glad that finally you’ve solved your problem. However, if you are interested in the root cause, you might want to try to create a clean directory and install with the default settings, i.e, do not change the default download folder and installation folder.

Hi Edward,

It turns out that the function sudo apt-get update/upgrade in our host PC is not working properly because it is trying to download for Jetson arch as well (arm64). After fixing the updates/upgrades, I was able to run JetPack 3.3 without errors anymore.

Thanks!

Thanks luis,
Glad to know your problem solved.

I have exactly the same problem. After clicking next in component manager the buttons just get greyed out for a few seconds. The sudo dialog does not appear. There is no error in the UI.

logs/jetpack_debug.log does not say much.

InstallUtils: Mon Nov 19 02:05:00 UTC 2018: /home/tmanthey/development/_installer/InstallUtil setup /home/tmanthey/development/ 199
InstallUtils: Mon Nov 19 02:05:05 UTC 2018: /home/tmanthey/development/_installer/InstallUtil setup /home/tmanthey/development/ 199
InstallUtils: Mon Nov 19 02:11:17 UTC 2018: /home/tmanthey/development/_installer/InstallUtil setup /home/tmanthey/development/ 199
InstallUtils: Mon Nov 19 02:11:19 UTC 2018: /home/tmanthey/development/_installer/InstallUtil setup /home/tmanthey/development/ 199
PageAction: Mon Nov 19 02:23:40 UTC 2018: /home/tmanthey/development/_installer/PageAction installation install . /home/tmanthey/development/ Launcher 142 /home/tmanthey/development/jetpack_download/
PageAction: Mon Nov 19 02:23:44 UTC 2018: /home/tmanthey/development/_installer/PageAction installation miscellaneous . /home/tmanthey/development/ Launcher 142 /home/tmanthey/development/jetpack_download/
InstallUtils: Mon Nov 19 02:24:00 UTC 2018: /home/tmanthey/development/_installer/InstallUtil setup /home/tmanthey/development/ 181
InstallUtils: Mon Nov 19 02:24:03 UTC 2018: /home/tmanthey/development/_installer/InstallUtil setup /home/tmanthey/development/ 181
PageAction: Mon Nov 19 02:27:56 UTC 2018: /home/tmanthey/development/_installer/PageAction installation install . /home/tmanthey/development/ Launcher 396 /home/tmanthey/development/jetpack_download/
PageAction: Mon Nov 19 02:28:00 UTC 2018: /home/tmanthey/development/_installer/PageAction installation miscellaneous . /home/tmanthey/development/ Launcher 396 /home/tmanthey/development/jetpack_download/
InstallUtils: Mon Nov 19 02:28:17 UTC 2018: /home/tmanthey/development/_installer/InstallUtil setup /home/tmanthey/development/ 432
PageAction: Mon Nov 19 02:46:52 UTC 2018: /home/tmanthey/development/_installer/PageAction installation install . /home/tmanthey/development/ Launcher 2265 /home/tmanthey/development/jetpack_download/
PageAction: Mon Nov 19 02:46:56 UTC 2018: /home/tmanthey/development/_installer/PageAction installation miscellaneous . /home/tmanthey/development/ Launcher 2265 /home/tmanthey/development/jetpack_download/
InstallUtils: Mon Nov 19 02:47:07 UTC 2018: /home/tmanthey/development/_installer/InstallUtil setup /home/tmanthey/development/ 2301
InstallUtils: Mon Nov 19 02:47:09 UTC 2018: /home/tmanthey/development/_installer/InstallUtil setup /home/tmanthey/development/ 2301

Hi manthey,

Have you updated your host PC successfully?

Did you see any attempts to download packages for arm64 architecture when running sudo apt-get update/upgrade?

Hi there is no activity to download anything. The sudodeamon window does not appear. I checked the network connectivity and that’s fine.