Jetpack 4.0 installation problem. (Solved)

When my Jetpack installation comes to “finished Flashing OS Determining the IP address of target…” then "JetPack is unable to determine the IP address of the Jetson Developer Kit " show up. I check lsusb before, there is a line of “NVidia Corp”.

Anyone know what to do?


Could you check if device is able to boot up? If it is able to boot up, could you see the IP of device?

Please use HDMI or typeC usb to dump the ifconfig for AGX.

Yes, it is able to boot up. And I did find the IP address of device with ifconfig command, but it is still fail to connect with manually input IP address.

Does command line ssh to either the “nvidia” or “ubuntu” account work without any prompts (meaning does it allow you to give a password without suggesting the host is unknown and not trusted)?

uh…yes I guess, I didn’t see it suggesting the host is unknown and not trusted. Is it related to my problem? I’m sorry, I’m new to this, I might need a little bit more detailed instructions. I installed the JetPack step by step just like the installation guide said, and this problem came up.

The first time you “ssh” to a host, the source machine doesn’t know about it, and you will typically tell the source that “yes, this is the host I intend to connect to.” Once you’ve told it to learn about that host, it will not warn again. This is a normal behavior of the SSH tool, so it can detect if someone tries to put another host with the same IP address, to somehow fool you. This warning is not typically a problem.

Do you know how can I solve my problem?I am really appreciate your answer.

Now that you’ve told ssh to accept this host (I assume you are using the same host PC account for ssh login as used for running JetPack) it might “just work”. You would still have to enter the address in the console of JetPack since the mechanism for automatically finding the address is only valid after a fresh flash.

There is a catch if you are not familiar with this though…each user account on the host PC which connects to that user at that remote host has to do this. Your regular user is one…another is root via “sudo”. Accept the unknown host from running manually as root as well: “sudo ssh root@where_ever_it_is”. After this ssh confirmations won’t be an issue during package installs.

During a flash USB is used…this is the lsusb step to confirm a recovery mode Xavier. After flash completes the Xavier reboots and the USB is no longer used…recovery mode should not be used after flash is complete as this won’t allow normal ssh and package install. The USB cable does not even need to be connected. JetPack will then use wired ethernet (and no USB is required) for package installs. Run this as a regular user, uncheck flash and only check packages (I suggest start only with CUDA on Xavier…you can rerun later for other packages), enter the password when needed, watch the console so you can know to enter the IP address, and it should allow package installs.

If this fails, then you can add a log here for just installing CUDA to the Xavier (this would simplify things and CUDA is the start of all of the other packages).

Thank you! I just solve my problem.