Jetpack 4.3 Flash error for Jetson AGX Xavier via Linux VM

I am using Mac, and installed Ubuntu18.04 VM on Virtual Box for Mac to flash Jetpack.
Downloaded the Jetpack 4.3 Developer preview and followed the command line steps from here:
on doing

$ sudo ./ jetson-xavier mmcblk0p1

it throws error and breaks the flash.

command tegraflash_v2 --pt flash.xml.bin --create
Failed flashing t186ref

Solution tried:

  1. lsusb shows Nvidia Corp.
  2. Installed python
  3. Installed xmr
  4. Jetson in recovery mode

Any help would be appreciated … I have tried it multiple times, using command line and sdk manager both but its breaking it both cases.

Hi Eyshika,

VMs are not supported by JetPack/SDK Manager, but you may refer to below topic to see if can help on your case:

Thank you for the reply. I am using the same method for VM and still getting error on flashing Jetson.

It is important to know that during a flash the USB repeatedly disconnects and reconnects. Even if you see the Jetson with lsusb prior to starting the flash a VM has a very high failure rate due to not reacquiring the USB reconnect. For this to work you would have to guarantee the host o/s never intercepts this and the Jetson is always passed to the VM no matter how often it reconnects.

@Eyshika, what sort of VM are you using? VirtualBox? Vmware?
Are you able to try flashing from Ubuntu OS without using VM, as the latter method is not officially supported?