Jetpack 4.3 flashing to Xavier

when I try to flash the OS onto the xavier I am getting the error “cannot connect to the device via SSH. Validate that SSH service is running on the device or use the ‘Manual Setup’ instead”. I SSH’d into the host machine and it is running. I have been trying for a while restarted and cant figure it out.

it seems like the address supposed to be assigned to it is i tried using username and password as nvidia, is there a default set that i should know? I tried SSH from terminal to get in and ssh nvidia@ it says permission denied (publickey, password). Any help appreciated!

From the host PC you should be able to “ping” (the Jetson is the “.1”, while the host PC will have “” visible via “ifconfig”). However, the first boot of the Jetson requires completing the one time setup for adding accounts. If you have not connected either monitor/keyboard or serial console, and added an account to ssh to, then ssh will always fail. Accounts are not created automatically anymore (accounts “ubuntu” and “nvidia” used to be added automatically).

Oh ok that makes sense, when does the one time setup usually pop up? i have a monitor connected with a dvi to hdmi into the xavier and usb keyboard into into a usb hub then into the usb c in the back of the xavier do you think that should work? thanks for the reply!

So long as video works, then this should be ok. Beware that not all DVI supports the automatic configuration wire (the DDC wire, which passes EDID configuration data), but if the adapter passes through that configuration data and video works, then it should be ok.

Right after flash, upon first boot, the login setup steps should show on the Jetson. During a flash the unit will reboot as soon as the flash part of the operation completes (or you could manually restart the Jetson so long as the flash completed). After this the unit is no longer used in recovery mode, and the address shows up as a result of the unit being fully booted. The account used with that address shows up only after you’ve completed that first time login…and this should be prompted for. If not, then sometimes this goes wrong.

Oh ok it might actually have something to do with the monitor it is pretty old lol, I’ll try a newer one with straight hdmi to hdmi and see if that helps any.

Even if the monitor in question is not valid, I think knowing why it causes an actual crash would still be valuable information. If it turns out that this issue is tied to the particular monitor, then you might still want to post details about the monitor.

Yep I was thinking the same, I’ll check back in when I try the new one.

It worked!!! So that was the problem, the monitor was a Samsung SyncMaster 931C going dvi to hdmi. Thanks for the help!! I would’t have thought otherwise had you not mentioned it might not support auto configuration. Its so sweet when up and running!

I have the same problem … any suggestions?

Your monitor needs to support EDID configuration, which typically means using a true HDMI monitor. Some DVI will also work, but it would need to be DVI-D.

Thanks. I solved the problem. I am using a true HDMI monitor.