Jetpack 4.4 install libjson-glib-dev fail

Hello all,

I use Jetson AGX Xavier and deepstream-5.0.
The OS is Jetpack 4.4.
I tried to compile deepstream-app.
But the compile fail.

nvidia@nvidia-desktop:/opt/nvidia/deepstream/deepstream-5.0/sources/apps/sample_apps/deepstream-app$ make

cc -c -o deepstream_app.o -DPLATFORM_TEGRA -I./ -I…/…/apps-common/includes -I…/…/…/includes -DDS_VERSION_MINOR=0 -DDS_VERSION_MAJOR=5 pkg-config --cflags gstreamer-1.0 gstreamer-video-1.0 x11 json-glib-1.0 deepstream_app.c
Package json-glib-1.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `json-glib-1.0.pc’
to the PKG_CONFIG_PATH environment variable
No package ‘json-glib-1.0’ found
deepstream_app.c:23:10: fatal error: gst/gst.h: No such file or directory
#include <gst/gst.h>
^~~~~~~~~~~
compilation terminated.
Makefile:57: recipe for target ‘deepstream_app.o’ failed
make: *** [deepstream_app.o] Error 1

It seem miss libjson-glib-dev.
I tried to install libjson-glib-dev.
But the install fail.
Could you give me suggestion?

apps/deepstream-app$ sudo apt-get install libjson-glib-dev
[sudo] password for nvidia:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package libjson-glib-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘libjson-glib-dev’ has no installation candidate

Best regards

-Jason

Hi all,

I fixed by myself.
download libjson-glib-dev from http://launchpadlibrarian.net/473495578/libjson-glib-dev_1.4.2-3ubuntu0.18.04.1_arm64.deb

nvidia@nvidia-desktop:~/Downloads$ sudo dpkg -i libjson-glib-dev_1.4.2-3ubuntu0.18.04.1_arm64.deb

Best regards

-Jason

1 Like

Glad to know,
but you can directly install,
sudo apt-get install libjson-glib-dev
you may meet another rtsp header issue,
do this,
sudo apt-get install libgstrtspserver-1.0