JetPack 4.4 - L4T R32.4.3 production release

We are pleased to announce the JetPack 4.4 production release supporting Jetson AGX Xavier series, Jetson Xavier NX, Jetson TX2 series, Jetson TX1, and Jetson Nano. (JetPack 4.4 replaces JetPack 4.3 as the latest production release.)

Please read an important NOTE at the end of this announcement

The JetPack 4.4 production release builds on top JetPack 4.4 Developer Preview, and includes production versions of TensorRT 7.1 and cuDNN 8.0.

Along with JetPack 4.4, we are introducing a web based Power Estimator tool to simplify creation of custom nvpmodel power profiles for Jetson.

Please refer to the JetPack Release Notes and L4T Release Notes for additional info.

JetPack 4.4 Highlights:

JetPack 4.4 components:

  • L4T R32.4.3
  • CUDA 10.2
  • cuDNN 8.0.0
  • TensorRT 7.1.3
  • VisionWorks 1.6
  • OpenCV 4.1
  • Vulkan 1.2
  • VPI 0.3 (Developer Preview)
  • Nsight Systems 2020.2
  • Nsight Graphics 2020.1
  • Nsight Compute 2019.3

Existing installations of JetPack 4.4 Developer Preview and JetPack 4.3 can be upgraded in-place to the JetPack 4.4 production release without re-flashing the device. For more information about upgrading JetPack via the Debian package management tool, please refer to the JetPack documentation here.

Download JetPack…

JetPack Release Notes…

L4T Release Notes…

Note: Jetpack/L4T upgrade using debian package management tool is now fixed and reenabled.

We had temporarily disabled the feature of upgrading JetPack or L4T using debian package management tool due to an issue we found in one of our debian packages causing the device to not boot properly. We have fixed this issue now and have reenabled this feature. We are sorry for the inconvenience caused.


If anyone get system stuck after running OTA update, please refer to this thread.


I installed JetPack 4.4 on tx1 from sctrach. When I run cuda samples with cuda-memcheck I get the following error:

cd /usr/local/cuda-10.2/samples/3_Imaging/histogram$

cuda-memcheck ./histogram
[[histogram]] - Starting…
GPU Device 0: “Maxwell” with compute capability 5.3

CUDA device [NVIDIA Tegra X1] has 2 Multi-Processors, Compute 5.3
Initializing data…
…allocating CPU memory.
…generating input data
…allocating GPU memory and copying input data

========= Program hit cudaErrorDevicesUnavailable (error 46) due to “all CUDA-capable devices are busy or unavailable” on CUDA API call to cudaMalloc.
========= Saved host backtrace up to driver entry point at error
========= Host Frame:/usr/lib/aarch64-linux-gnu/tegra/ [0x2fd95c]
========= Host Frame:./histogram [0x3cf0c]

CUDA error at main.cpp:81 code=46(cudaErrorDevicesUnavailable) “cudaMalloc((void **)&d_Data, byteCount)”
========= ERROR SUMMARY: 1 error

On the other hand, When I run the same sample without “cuda-memcheck”, it runs successfully.
In my own code (that runs successfully on tx1 jetpack 3.3, nano jetpack4.3) I get the same memory check error. Is it safe to deploy jetpack 4.4 on tx1?