JetPack 4.4 - L4T R32.4.3 production release

Does JetPack 4.4 support for TensorFlow?

Thanks

Yes. You can get TensorFlow wheels from here:

Also, we have released Tensorflow container for JetPack 4.4 on NGC
https://ngc.nvidia.com/catalog/containers/nvidia:l4t-tensorflow

Thank you and sorry to bother you again.
JetPack 4.4 support for TensorFlow in python.
Does JetPack 4.4 support for TensorFlow in C, is there any C API?

@AastaLLL, would you be able to help here with TF C API question.

Is this BSP source package includes cboot source code ? if not can you provide the link for latest cboot ?

@suhash,@AastaLLL This is just a friendly reminder that I’m waiting for your reply.

Hi, ayase_yu

For TensorFlow python interface, please use the v2.2.0+nv20.6 or v1.15.2+nv20.6 package.
Detail installation steps can be found here:
https://docs.nvidia.com/deeplearning/frameworks/install-tf-jetson-platform/index.html

We don’t support C++ interface currently, some user have built it from source for JetPack4.2.
You can check their building steps and compile it on the JetPack4.4:

Thanks.

Hi,AastaLLL

Thank you for your reply.We’ve tried all the steps.Bute it doesn’t work for JetPack4.4.

May I know if the demo works on 4.4? (jetson-cloudnative-demo) Have anyone tried?
I just bought a Xavier NX but I couldn’t get the demo work. I suspect it is the version problem. Thx

Hi AK51,

The demo is not updated for Jetpack 4.4 GA but you can use Jetpack 4.4 Developer preview to try out the demo.

If I want to run the demo, shall I just burn another SD card with 4.3? Do I need to do any setting of my SSD?
I wonder what is a effect if I have one SD card with 4.3 and another one with 4.4. Can I just swap them without affecting the SSD?
Btw, what is the Jetpack 4.4 Developer preview? May I run in one my board?
And where I can find the jetpack 4.3 in Nvidia website? I can’t find it in achieve…
Thx

The demo is not supported on JetPack 4.3. It is supported on JetPack 4.4 Developer Preview only. Check https://developer.nvidia.com/jetpack-sdk-44-dp-archive for JetPack 4.4 DP release and to dowload an SD card image for the same.
The demo requires to setup a NVME andrequires some configuration (like creating a disk swap on the NVME, etc) which is stored on the SD Card image. The NVME is used by the demo to only store the pulled docker images.
So if you want to switch between JetPack 4.4 Developer Preview and JetPack 4.4 Production release, you can create 2 SD Card images and swap them without effecting the SSD.

Yep, it is working, thx.

I tried to burn another image to the SD card, but my laptop can not recognize the SD card. The SD formatter can not show the SD card. Does the demo image have some setting that prevent me to re-burn the card… Thx

I tried to install pytorch on the Xavier using the demo image but it fails. When I do the import, the program can not find the library.
I wonder if it ok to keep using the demo image for my development or I should switch to 4.4.
Thanks,

Hi @AK51, it does not have such a setting. However, some microSD-to-SD card adapters have a little switch on the side that toggles on write-protect mode - perhaps this got pressed. Those adapters are what you put a microSD card into to be able to insert it into a full-size SD card slot.

1 Like

If you are currently on JetPack 4.4 Developer Preview (L4T R32.4.2), did you install a PyTorch wheel for R32.4.2?

JetPack 4.4 Developer Preview (L4T R32.4.2)

Alternatively, you could use the l4t-pytorch:r32.4.2-pth1.5-py3 Docker container, which has PyTorch pre-installed for you already.

Thx. I bought another 128Gb SD card with 4.4, It works now.

There is no switch…
In the past, I could burn different image to the 32G SD card.
But after I burned the demo image to this 128Gb SD card, SD formatter can not see the SD card anymore. It is weird.