Jetpack 4.5.1 SD Card Image Error: end of central directory record signature not found

I downloaded Jetpack 4.5.1 SD Card Image for Jetson Nano Developer Kit, but got an error in Etcher (Windows):

Error: end of central directory record signature not found.

Also tried unzipping the via WinRAR and WinZip as suggested here, but it says the zip file is corrupted.

At some other thread it was suggested to try in Linux, but unfortunately I don’t have access to Linux right now.

Any help is really appreciated!

What is the version of etcher on your Windows?

Solved with Jetpack 4.5.0,

Etcher was the newest ver as of this writing, 4.5.1 was definitely the problem.

But thanks anyway! @WayneWWW

1 Like

Although I solved this error with Jetpack 4.5.0, a camera/GStreamer error forces me to download older versions (4.4 or older)

So, I tried Jetpack 4.4.1, 4.4.0 and also 4.3.0 all have the same error:
end of central directory signature not found

I had to wait 6 hours for each download, so I would really appreciate if anyone can help. Thankyou!

Things I have tried:

  • using Etcher via Windows
  • WinRAR, WinZip, 7z to unzip (same error, and the blob img file is unusable when mounted in Jetson Nano)
  • Unzip via terminal in Linux (same error)

I don’t think the card image itself is the cause of this problem. since no other users report this issue for quite long time.

The only few thread that I can find is this link.

Also, some discussion over the Internet.

Maybe you can try 7z on your linux?

Hi @WayneWWW thanks for your ideas.

I tried the 7zip:
$ 7z x ~/

7-Zip [64] 16.02 : Copyright (c) 1999-2016 Igor Pavlov : 2016-05-21
p7zip Version 16.02 (locale=en_US.UTF-8,Utf16=on,HugeFiles=on,64 bits,4 CPUs LE)

Scanning the drive for archives:
1 file, 5642977266 bytes (5382 MiB)

Extracting archive: /home/steve/

Unexpected end of archive

Path = /home/steve/
Type = zip
Unexpected end of archive
Physical Size = 6450819350

ERROR: Data Error : sd-blob-b01.img
Sub items Errors: 1

Archives with Errors: 1

Open Errors: 1

Sub items Errors: 1

But as it produced blob img anyway, I copied it to my Windows and used Etcher. I put it in the Jetson Nano, and it won’t start:

At this point I am sure if not the file itself, then perhaps some data is lost when downloading from server. (But, the strange part is, Jetpack 4.5.0 works for me but not other versions)

Would you have another download mirror or other advice?

If you have a non-VM ubuntu host, I would suggest you can also try sdkmanager. This is different path from sdcard image.

You just need a empty card and let sdkmanager do the flash work.

Hi @WayneWWW I tried to do that but unfortunately the only ubuntu I have is the Jetson Nano where the Jetpack 4.5.0 was installed. Would there be another way for Windows?


Then your 7z work is also on the jetson nano?

Are you sure the disk space size is enough for doing this work? Please note that it is 6gb zip file and you will get a larger one even after you decompress it out.

Hi @WayneWWW Yes, 7z was on the Jetson Nano, and I have 64GB microSD so space was not an issue.

Meanwhile, I am redownloading Jetpack 4.4.1. I hope it works this time.

How about you compare the md5sum on your device?

We provide the md5sum here

Hi @WayneWWW your suspicion is correct, they are not matched:

whereas the working 4.5.0 has a matched checksum

One user said the Chrome breaks his image. How about you change the browser?

@WayneWWW Yeah I am indeed using Chrome and also thought the same.

So, I am trying with Free Download Manager now. Download should finish under 1 hour and I will confirm whether Chrome is the problem so other users can avoid this problem.

@WayneWWW It works! You are right, Chrome is the problem.

For anyone reading this, use something like Free Download Manager.

Thanks Wayne, I really appreciate your help!

1 Like