JetPack 4.5 Production Release with L4T 32.5

We are pleased to announce JetPack 4.5, a production release supporting Jetson AGX Xavier series, Jetson Xavier NX, Jetson TX2 series, Jetson TX1, and Jetson Nano.

JetPack 4.5 includes VPI 1.0, Security features including enhanced secure boot and support for full disk encryption, enhanced bootloader functionality, and a new way of flashing Jetson devices using NFS.

We will be hosting a webinar on Feb 9th for an in-depth overview of JetPack 4.5 features where we will also demo select features and answer any questions you may have. Please register here.

Learn how to implement computer vision and image processing pipelines using VPI by registering to the webinar we will be hosting on Feb 11th

Highlights of JetPack 4.5 are:

  • First Production release of Vision Programming Interface (VPI).
  • Support for Docker 19.03.
  • Support for installing JetPack components on Linux host computer using Debian package management tool.
  • Disk encryption supported to protect data at rest.
  • Support for loading kernel, device tree and initrd from the root file system on USB drive or NVMe. Refer to release notes for more details.
  • UBoot version updated to v2020.04.
  • New way of flashing eMMC, SDCard, USB or NVME connected to Jetson using Network File System.

Visit JetPack 4.5 and L4T 32.5 page for more details.

JetPack 4.5 components:

  • L4T R32.5
  • CUDA 10.2
  • cuDNN 8.0
  • TensorRT 7.1.3
  • VisionWorks 1.6
  • OpenCV 4.1.1
  • Vulkan 1.2
  • VPI 1.0 (First Production Release)
  • Nsight Systems 2020.4
  • Nsight Graphics 2020.5
  • Nsight Compute 2019.3

Install JetPack 4.5 using SDK Manager or upgrade via Debian package management tool (refer instructions from here)

Notes: (We will update this announcement accordingly when we take care of below notes)

Hi Folks,

I used Ubuntu 20.04 on my host and it looks like I didn’t hit an issue. I just replaced the lsb-release file. The only three packages that failed, it for vision API. In essence, SDK Manager is trying to poll one minor version behind.

Is there any option in SDK Manager to adjust the version for a minor release for dependencies? For example, if you need libX5.1 and you want to change that to LibX5.2.

Thank you

Hi spyroot,

No, that’s not supported.

Is there a log which bugs were fixed for this release, e.g. in the Multimedia API (Buffer API, Encoder, Decoder)?