JetPack 4.5 Unable to locate software modules

Just tried to use JetPack 4.5. Install and initial config had no issues. However, installing new packages does not work the same as the previous releases. My scripts use “sudo apt-get” and they all result in “Package xxx is not available, but is referred to by another package.” I have used this same script for at least the last 2 JetPack releases without issue. What has changed?

I don’t know what inside your script. Could you describe what kind of command is in that and what kind of software you want to install?

What would happen if you directly run the command in terminal instead of running a script?

Do you ever run apt-get update before installing?

Script beginning is shown below. I have used this script on at least 10 different Linux/hardware systems without issue as I port my software to different platforms. It worked just fine on JetPack441.
Yes I have run sudo apt-get update and sudo apt-get upgrade.
Running in command line gets the same response.
Here’s the script

sudo apt-get -y install \
autossh \
build-essential \
checkinstall \
cmake \
curl \
doxygen \
git \
and the list of packages continues.

I get the same error if I try to run the installs one package at a time.

So I just started over with a fresh image. Seems to be working this time. Not sure what was different other than I did the installs before doing apt-get upgrade.

1 Like

If you figure out how to reproduce this issue, please tell us. Thanks.