Jetpack 5.0.2 flashing with kernel-dtb doesn't update the device tree

I have flashed my Xavier NX Devkit with SD Card with the new Jetpack version 5.0.2. For developing some camera drivers I need to modify the device tree files and flashing them repeatedly. With older Jetpack version it was not problem to do that with
./flash.sh kernel-dtb jetson-xavier-nx-devkit mmcblk0p1

With the new Jetpack version I do face the problem that the device tree isn’t updated anymore. What could be the reason and how can I fix this?

You can check if you /boot/extlinux/extlinux.conf has a device tree location or not.

If there is, then this path will have higher priority than loading from partition. What you are doing now (flash.sh -k xx) is flashing things to partition.

Removing the path in extlinux.conf and device tree in partition shall take effect then.

1 Like

Hello Wayne, thanks a lot this solved my problem. I commented out the device tree entry. My extlinux.conf now looks like that:

LABEL primary
      MENU LABEL primary kernel
      LINUX /boot/Image
#      FDT /boot/dtb/kernel_tegra194-p3668-0000-p3509-0000.dtb
      INITRD /boot/initrd
      APPEND ${cbootargs} root=/dev/mmcblk0p1 rw rootwait rootfstype=ext4 console=ttyTCU0,115200n8 console=tty0 fbcon=map:0 net.ifnames=0 

# When testing a custom kernel, it is recommended that you create a backup of
# the original kernel and add a new entry to this file so that the device can
# fallback to the original kernel. To do this:
#
# 1, Make a backup of the original kernel
#      sudo cp /boot/Image /boot/Image.backup
#
# 2, Copy your custom kernel into /boot/Image
#
# 3, Uncomment below menu setting lines for the original kernel
#
# 4, Reboot

# LABEL backup
#    MENU LABEL backup kernel
#    LINUX /boot/Image.backup
#    FDT /boot/dtb/kernel_tegra194-p3668-0000-p3509-0000.dtb
#    INITRD /boot/initrd
#    APPEND ${cbootargs}

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.