Jetpack 5.0.2 - Nvidia Jetson Xavier NX - Boot device

Hi,

I’m testing Jetpack 5.0.2 on our custom carrier board hosting Nvidia Jetson Xavier NX.
When I boot the system without NVMe plugged the system boots fine, when I plug the NVMe the system doesn’t boot.
Comparing the boot logs with and without NVMe I see that the boot hangs before the boot option selection:

Jetson UEFI firmware (version 1.0-d7fb19b built on 2022-08-10 <
Press ESCAPE for boot options ** WARNING: Test Key is used. <

What can be the problem here?
With Jetpack 4.6 the NVMe works fine, it feels like a UEFI bug.

Thanks,
Filippo

Attaching boot logs with and without NVMe.

BR
No_NVME.log (94.9 KB)
NVME.log (11.1 KB)

Have you checked the UEFI Adaptation — Jetson Linux
Developer Guide 34.1 documentation (nvidia.com)

Hi Kayccc,

I tried to build UEFI but without success, the build fails as in :

From that thread I’ve downloaded UEFI debug image and installed it in the SOM.
Output attached.

It looks like the system hangs just after installing the PCIe Controller DXE driver:

add-symbol-file /vol/nvidia-l4t-jetson-uefi-source/uefi/Build/Jetson/DEBUG_GCC5/AARCH64/Silicon/NVIDIA/Drivers/PcieControllerDxe/PcieControllerDxe/DEBUG/PcieControllerDxe.dll 0x2547EE000
Loading driver at 0x002547ED000 EntryPoint=0x002547F5178 PcieControllerDxe.efi
PROGRESS CODE: V03040002 I0

Any hint?

UEFI_Debug.log (37.1 KB)

Hi,

Sorry to say that. But could you remove every PCIe device you have connected on your jetson one by one and see which one is causing the problem?

If PCIe is not the device that is causing hang, please also share me the UEFI log after you removed all pcie device.

Hi Wayne,
As reported above, the issue appears when I plug the NVMe to PCIe 0 port.
I tried 2 different NVMe brands but the issue is the same.

Thanks,
Filippo