Jetpack 5.0.2 with Jetson Linux 35.1 is now live!

Update: Power Estimator for Jetson AGX Orin and Jetson Xavier NX are now live!

Hello…

I am trying to access the Jupyter on a remote machine in my lab - headless. It now needs token before you can change the password. The original nvidia password does not work. Attempting to persist a new password does not work because this is a docker container and is deleted in jupyter server when the container is removed. Is there a simple way to get the autogenerated token without doing a “server list” command and typing the token in on the remote machine? We do not want to run the graphics on the Xavier.

Thank you.

Hi @marvinbr, since Jupyter has changed the way it authenticates passwords/tokens, what I would recommend to persist a new password is after setting the new password, to save your changes to the container image with docker commit. Then afterwards, run your new container image instead.

You can get the tokens remotely by running jupyter server list from a terminal into your docker container, it doesn’t need to be done from the Jetson itself with a display attached.

2 Likes

Awesome …Thank you both. Both processes work. I will use the remote access version using SSH.

Why do we get this screen?


.

Will the new Jetpack 5.0.2 support UEFI Secure Boot? If yes for which Nvidia Jetson?

Thanks!
Max

@Max_Dichler securboot is supported till bootloader in this release for both Xavier and Orin (i.e, MB1, MB2 and until UEFI). In the next release we will support UEFI secureboot to sign componetns above UEFI like the kernel.

This release does not install for me on NVMe with the Jetson Xavier NX Developer Kit. Multiple attempts. It seemed to install successfully on uSD card, but my goal is to install to NVMe. I’m using latest SDK manager, JetPack 5.0.2 Rev 1. Was hopeful this would address the ridiculously bad installation problems of JetPack 5.x thus far. I am using manual install to SD and NVMe (the automatic install option never works at all).

Logs are attached. Everything I’ve tried with multiple, separate U20.04 host machines and multiple dev kits for NX and AGX have been enormous, time-wasting failures to install correctly.
SDKM_logs_JetPack_5.0.2_(rev.1)_Linux_for_Jetson_Xavier_NX_modules_2022-09-11_14-38-41.zip (428.4 KB)

It might also be helpful to know that no matter how I install it (NVMe/SSD) it never boots from NVME. It will never come up with NVMe mounted as the root filesystem. The NVMe device is recognized as nvme0n1 when the device is booted. It can be formatted and accessed normally by Linux on the device, but installation always fails to work properly.

Well it appears that it worked this last time because I removed the uSD card from the NX module. So perhaps this works now? Previously it would not let me flash NVMe first without flashing the image to the uSD card, but this last time it seems to have succeeded.

you are lucky! i have embed 16G eMC onboard. no chance to remove it. So I have to flash SD card.

Same here cannot flash 502 while 462 works fine on xavier nx nvme :

created new topic for this:

cannot flash 502 on NX

I can’t flash Jetpack 5.0.2 using SDK manager to nvme on Xavier NX either. SD card works fine. I’m using the official developer kit with SN750 500GB SSD.

1 Like

Ho that looks worst that I thought, was about to buy an official nx dev kit to replace custom carrier board.

5.0.1 works for you also?

No. I can’t flash 5.0.1 to nvme either. It shows the same error.

I think it’s a different issue.

Did you try to remove all usb devices and only keep the jetson in recovery mode?

Yes I did. I reformatted the SSD and tried it again this morning. It still gave the same error. I have no problem flashing either 5.0.1 or 5.0.2 to the uSD card using SDK manager. I’ve given it up now and use the rootOnNVMe method instead.

1 Like

Strange, I managed to get my custom carrier board working with 5.0.1 on nvme but no luck 5.0.2.
Was about to buy an original dev kit, but I think there are too much issue with those boards and 5.0.2.

Is there a response to this question. We randomly get this screen at bootup and boot failure if no manual entry, how can this screen be automatically bypassed or boot selection permanently stored

1 Like

Hello All, may i suggest to create new issue on the problem you are facing. Our forum staff will be able to provide the needed help.