JetPack download - page not found / repeats downloading driver packages

Hi,

I’m getting a page not found message when trying to download JetPack from https://developer.nvidia.com/jetpack-archive. I am logged in as a registered developer, of course.

Please fix, guys.

Thanks

The Download button in https://developer.nvidia.com/jetson-tk1-development-pack works, but if you go to the Install Guide, the link there is currently broken.

The JetPack installation never gets past the “Downloading the Driver Packages” stage. It downloads 58/58MB and then says that the downloaded file is broken and repeats to infinity.

There was also an issue with the R19.3 sample rootfs which I know someone from nVidia is looking into. Perhaps it is the same issue.

Uriv

For the driver package download issue, what’s your locale?

uriv,

Can you please remove the <Install_directory>/jetpack_download directory and restart the downloading process?

Hi Uriv,

As suggested by Edward, please try by deleting the installation directory .

If you have attempted to install as root/sudo user, your default installation directory should be under /opt.
Delete if you find any file jdp_vars.txt in your home directory before starting installation.

Also try picking the latest JetPack https://developer.nvidia.com/jetson-tk1-development-pack

if your issue persists , please let us know the Host OS details and also attach the Jetpack Installer log which gets created in installation directory.

I am stuck in the Download Components loop as well. The popup says “The downloaded file is broken, will restart downloading soon” I am using Ubuntu version 12.04 and my jdp_vars.txt file has the following:

cuda_l4t_revision=006
cuda_l4t_ver=cuda-repo-l4t-r21.3-6-5-prod_6.5-42_armhf.deb
cuda_l4t_sha1sum=4c262429c39705fed0fe9a37673a41153e5783aa

cuda_ubuntu12.04_revision=006
cuda_ubuntu12.04_ver=cuda-repo-ubuntu1204-6-5-prod_6.5-42_amd64.deb
cuda_ubuntu12.04_sha1sum=0ccf92058ae07e5cfad6ababd8e319b2365a5e37

After trying various Installation options in the JetPackTK1 installation program (Express, Custom with everything except OpenCV selected, Custom with just CUDA for Ubuntu 12.04 selected) I noticed the following in the JetPackTK1-1.1/jetpack_download directory:

user@comp:~/JetPackTK1-1.1/jetpack_download$ sha1sum cuda-repo-l4t-r21.3-6-5-prod_6.5-42_armhf.deb 
0267e564fe15c50739a57e113b9feaff0c5e9a0e  cuda-repo-l4t-r21.3-6-5-prod_6.5-42_armhf.deb 
user@comp:~/JetPackTK1-1.1/jetpack_download$ sha1sum cuda-repo-ubuntu1204-6-5-prod_6.5-42_amd64.deb 
073d6badb21a07cbfef85772293c87f176db9c4b  cuda-repo-ubuntu1204-6-5-prod_6.5-42_amd64.deb

I have tried deleting the JetPackTK1-1.1 directory and re-running the JetPack installer multiple times. Each time results in an identical mis-matching checksum. I was thinking about upgrading to Ubuntu 14.04, then rerunning the JetPack installer, but, that is not an option for me.

I downloaded the JetPack Installer via the following url:
http://developer.download.nvidia.com/devzone/devcenter/mobile/files/L4T/jetpack_tk1_1.1/02/JetPackTK1-1.1-cuda6.5-linux-x64.run

Lastly, the JetPackTK1-1.1/_installer/logs directory is empty. How do I resolve this?

Hi, krowe,

Can you please manually download these two files and put them in JetPackTK1-1.1/jetpack_download directory, then go on installation? You can get the URL on a popup window after canceling the downloading application in JetPack.

The JetPackTK1-1.1/_installer/logs directory will be used in later steps after downloading.

Thanks very much EdwardZhou! that worked!

@krowe and @ EdwardZhou: I’m really glad that I found this forum thread and that your discussions led to the solution for this issue, because just today I also ran into the same problems that @krowe had regarding the downloading of these packages by Jetpack. Like @krowe, I had the same problems of the infinite looping of [Download -> Downloaded file broken -> repeat], but compared to what @krowe encountered, I had that problem for many more packages than just the two files which @krowe was grappling with.

I chose to install all available packages during the Jetpack configuration, and @EdwardZhou I had to apply your solution of manually downloading the files and copying them to the jetpack_download directory for about all the files you can see that I listed below in the folder, except for I think the gl-graphics-compute-samples-linux-2.1.zip and one other file which I can’t recall now…

I have also done a listing of the SHA checksum for all the packages; I’m not too sure how to infer from the checksum if there are any problems - is anything wrong?

➜  jetpack_download  ls       
2.2.19311905-linux-x64.tar.gz                   gl-graphics-compute-samples-linux-2.1.zip                                         Tegra124_Linux_R21.3.0_armhf.tbz2
cuda-repo-l4t-r21.3-6-5-prod_6.5-42_armhf.deb   libopencv4tegra-repo_l4t-r21_2.4.10.1_armhf.deb                                   Tegra_Linux_Sample-Root-Filesystem_R21.3.0_armhf.tbz2
cuda-repo-ubuntu1404-6-5-prod_6.5-42_amd64.deb  NVIDIA_Tegra_Graphics_Debugger_1.3.15044.1937_Release_External_linux-v3l_l4t.run
docs.zip                                        PerfKit-4.2.3-l4t.tar.gz
➜  jetpack_download  sha1sum *
97199ffa61c7a4c531e48db7e4e54f1910138078  2.2.19311905-linux-x64.tar.gz
4c262429c39705fed0fe9a37673a41153e5783aa  cuda-repo-l4t-r21.3-6-5-prod_6.5-42_armhf.deb
57c80a5234c65006f7165d7393b4ad9c6cd4fb84  cuda-repo-ubuntu1404-6-5-prod_6.5-42_amd64.deb
2b387d3080ff6bb6524d1163d279decbc64b2fb5  docs.zip
0b01b06d1210781a315cd5988fc5f5e23b60a2d5  gl-graphics-compute-samples-linux-2.1.zip
427c4e9979f7fa6644d4ad1c30f2f610207871bd  libopencv4tegra-repo_l4t-r21_2.4.10.1_armhf.deb
1169528083c7fc61c9b85a3885860d1875729493  NVIDIA_Tegra_Graphics_Debugger_1.3.15044.1937_Release_External_linux-v3l_l4t.run
4714dbdcf4036b52e6fd92a8082ba1790afd2c0f  PerfKit-4.2.3-l4t.tar.gz
d3740d753ad8f139d22f2eec1008156f05a249ba  Tegra124_Linux_R21.3.0_armhf.tbz2
bf310e64336ce49a99f80b67e6b5dc8650cb16c5  Tegra_Linux_Sample-Root-Filesystem_R21.3.0_armhf.tbz2

The lucky thing is that each time for some Download that failed, upon closing the download window, we would see the URL at from which the package download was attempted, and I was able to just visit each of those download links manually from my browser and shift the files over to the directory for downloading.

This problem can really trip people attempting to configure their Jetsons; I really Nvidia fixes this up man. Do they know about it?
Is there anyway to feedback this to them?
What could be the cause of this problem in the Jetpack installer???

Cheers,
Augustine