JetPack Flashing freezes at "Writing partition APP with system.img"

Hello everyone,

I am trying to flash my Jetson TX1 after it didn’t boot properly when I bought it. It freezes at “Writing partition APP with system.img” each time I try to install JetPack. I have tried this 4 times at it has frozen at 33%, 2%, 64% & 9%. I have waited around 1/2 an hour to an hour to see if it caries on, and it does not.

I have also tried in different USB ports as well as JetPack 2.2.1 & 2.2. When it has frozen I have just simply removed the USB cable and re-tried. Also, I am using Ubuntu 14.04 (VirtualBox VM) as the host computer.

If you have any ideas on what I can do to fix this, I will be grateful.

Thanks,
Billy

A VM for host has many issues reported, often with USB issues or halting. Sometimes it works, but I get the feeling that it has to be set up very carefully. Someone may have an idea for what to adjust on USB for the VM, but just beware you may be in for “significant effort” before it does as desired. For someone to comment on a possible adjustment you may want to give more specific information about the host o/s.

I just had the same issue and resolved it by setting USB to EHCI.

Same solution for me (USB 2.0) … by default mine was 1.0 and there was no way it was happening. I had problems with 3.0 as well.

I’d also recommend starting usbmon in another shell tab to keep an eye on traffic. You’ll know exactly when it stops if it does.

sudo modprobe usbmon
lsusb
sudo cat /sys/kernel/debug/usb/usbmon/<busnum>u    # replace <busnum> with NVidia USB bus number

The actual flash port runs USB2…I’d be suspicious of 1.0, and guarantee 3.0 would have to downgrade to 2.0.

Thank you for the reply’s

I set up an Ubuntu dual boot instead of using a VM, and that worked, but I will try setting USB to EHCI for the VM to see if that works too.

I had this problem too and downgrading USB in VirtualBox VM settings from 3.0 to 2.0 worked.

Thank you

P.S.: an alternative to usbmon is to use the serial console

I faced the same issue, and solved it. Thanks!
To enable USB 2.0 in your virtualbox vm, download the Extension Pack and install it.
Use the same version of it.
https://www.virtualbox.org/wiki/Downloads

Dear all,

$ sudo modprobe usbmon
$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 8087:0aa7 Intel Corp. 
<b>Bus 001 Device 015: ID 0955:7f21 NVidia Corp. </b>
Bus 001 Device 005: ID 0461:4e66 Primax Electronics, Ltd 
Bus 001 Device 004: ID 046d:c31c Logitech, Inc. Keyboard K120
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

sudo cat /sys/kernel/debug/usb/devices | grep -E "^([TSPD]:.*|)"

T:  Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=480  MxCh=16
D:  Ver= 2.00 Cls=09(hub  ) Sub=00 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=1d6b ProdID=0002 Rev= 5.00
S:  Manufacturer=Linux 5.0.0-23-generic xhci-hcd
S:  Product=xHCI Host Controller
S:  SerialNumber=0000:00:14.0

T:  Bus=01 Lev=01 Prnt=01 Port=04 Cnt=01 Dev#=  2 Spd=12   MxCh= 0
D:  Ver= 2.00 Cls=e0(wlcon) Sub=01 Prot=01 MxPS=64 #Cfgs=  1
P:  Vendor=8087 ProdID=0aa7 Rev= 0.01

T:  Bus=01 Lev=01 Prnt=01 Port=10 Cnt=02 Dev#=  4 Spd=1.5  MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=046d ProdID=c31c Rev=64.02
S:  Manufacturer=Logitech
S:  Product=USB Keyboard

T:  Bus=01 Lev=01 Prnt=01 Port=11 Cnt=03 Dev#=  5 Spd=1.5  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=0461 ProdID=4e66 Rev= 1.00
S:  Manufacturer=PixArt
S:  Product=HP USB Optical Mouse

[b]T:  Bus=01 Lev=01 Prnt=01 Port=12 Cnt=04 Dev#= 15 Spd=480  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=0955 ProdID=7f21 Rev= 1.02
S:  Manufacturer=NVIDIA Corp.
S:  Product=APX[/b]

T:  Bus=02 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#=  1 Spd=5000 MxCh=10
D:  Ver= 3.00 Cls=09(hub  ) Sub=00 Prot=03 MxPS= 9 #Cfgs=  1
P:  Vendor=1d6b ProdID=0003 Rev= 5.00
S:  Manufacturer=Linux 5.0.0-23-generic xhci-hcd
S:  Product=xHCI Host Controller
S:  SerialNumber=0000:00:14.0

$ sudo cat /sys/kernel/debug/usb/usbmon/u # replace with NVidia USB bus number

How to supply for my system?

Thank you very much in advance.

Warmest Regards,
Suryadi

@suryadi: This should really be a new thread since usbmon is unrelated to usb flashing issues. You might take a look at this:
https://www.kernel.org/doc/Documentation/usb/usbmon.txt