Jetpack install--problems post-flash

Hi,

I’ve just worked through the instructions for installing Jetpack, essentially those that can be found here:
http://developer.download.nvidia.com/embedded/L4T/r23_Release_v1.0/NVIDIA_Jetson_TX1_Developer_Kit_User_Guide.pdf

I’ve gone up to the part where the Jetson TX1 is flashed with the new OS image, what happens next is that I am prompted for an IP address, username and login for the board. However, because the device has just been flashed, I do not know what the username/login are for the board. I tried ubuntu/ubuntu, this did not work…also, I tried restarting the board in non-recovery mode, what came up was a console-based login prompt:

tegra-ubuntu login:

It does not seem to like “ubuntu” as a username. Basically, what username/password should I use? How do I proceed?

Thanks so much

By default, the username is ubuntu, password is ubuntu.

It sounds like you are seeing this dialog, which normally shouldn’t happen (only if you de-selected ‘Flash OS’ step):

I would try going through it again and having Jetpack re-flash everything with default settings.
You should have your desktop machine and Jetson plugged into the same DHCP-enabled router over ethernet.
This is so that Jetpack is able to SSH into your Jetson from the desktop, and perform the post-install steps. If Jetpack is able to perform these steps, you know it was able to login ok with ubuntu/ubuntu credentials.

If the issue persists, you can try running the command to flash Linux4Tegra yourself (normally Jetpack does this), see here: http://developer.download.nvidia.com/embedded/L4T/r23_Release_v1.0/l4t_quick_start_guide.txt
You should find the L4T binaries downloaded under the Jetpack downloads folder that it creates.

Thanks for the reply! :D

Yes, the problems are persisting. Everything is connected to a DHCP-enabled server. One question–after the flash is complete, I’m supposed to restart the Jetpack in non-recovery mode, and then it’s supposed to get an IP address via DHCP, right?

I made some progress on the Jetson side, it does come up with a login prompt on tty1 that does not accept username “ubuntu.” However, if I Ctrl-Alt-F7 over to tty7, it looks like there are (upstart?) initialization messages, some of which fail with permission problems, and it looks like the initialization is actually hung. From this, I’m concluding that (1) the system is never coming up normally, so it’s never doing DHCP and (2) something is wrong with the system flash step. Also I’ve tried numerous times with the same result so probably I’ll try the instructions from the quick start guide that you posted above and see if something different happens.

Also, maybe two more things:

  1. Are there any known problematic versions of Jetpack out there? Maybe I should try doing the Jetpack download/install again with a different version
  2. The HDMI output seems to work inconsistently, generally when the Jetson boots the connector has to be unplugged/replugged in a few times before the monitor detects it. This isn’t fatal, but I’m wondering if anyone else has had this issue, or maybe it’s just a problem with (both) monitors I’ve tried it with.

Thanks so much again for your reply!

Is your host just a standard 64-bit Ubuntu 14.04 desktop?

Yes, thanks for your response, I’m using VMWare virtualization to run Ubuntu 14.04.3.

At this point any help at all would be appreciated as I basically have 2 bricked Jetson TX 1’s due to this problem with firmware install.

Also, I tried again, there are some initialization messages that are showing up on tty7:

/etc/init.d/rc: 121: /etc/init.d/rc: /etc/rcS.d/S25brltty: Permission denied
/etc/init.d/rc: 121: /etc/init.d/rc: /etc/rcS.d/S26cryptdisks-early: Permission denied
/etc/init.d/rc: 121: /etc/init.d/rc: /etc/rcS.d/S55urandom: Permission denied
/etc/init.d/rc: 121: /etc/init.d/rc: /etc/rcS.d/S70x11-commonn: Permission denied

/etc/init.d/rc: 121: /etc/init.d/rc: /etc/rc2.d/S20kerneloops:Permission denied

/etc/init.d/rc: 121: /etc/init.d/rc: /etc/rc2.d/S20rsync: Permission denied
/etc/init.d/rc: 121: /etc/init.d/rc: /etc/rc2.d/S20speech-dispacher: Permission denied

This is post-flash, so I’m guessing something wrong with the image or the flashing procedure.

It is a significant probability that file permissions were not preserved. Even if you unpacked the sample rootfs and used root permissions/sudo for the apply_binaries.sh script, permissions will fail in this manner if the underlying file system is not native Linux, e.g., ext4. If you are unpacking to an NTFS file system, the install cannot succeed (the install may proceed and appear to work, but still be invalid).

Was your vmware Linux running on a native ext4 file system?

I know it’s dumb but when the terminal pops up and starts the process, about halfway though it will say something like “Restart the Jetson” This is not a command, it’s telling you that it’s rebooting the system. Furthermore, make sure the USB cable stays in the entire time. If you see the dialog box that dusty posted, restart your TX1, go to the desktop and run ifconfig in the terminal. You’ll see the ip address you have to type in the box. Note the ip down and restart your TX1 in recovery mode with the usb cable connected, type in the ip and ubuntu as the user name and pass. The terminal should pop up and install and configure all the CUDA and Visionworks stuff.

Also

The display takes about 5 seconds to appear after you press the power button, you just have to be patient.

Thanks for all the responses.

For the flashing issue, everything worked correctly after following these instructions:
http://developer.download.nvidia.com/embedded/L4T/r23_Release_v1.0/l4t_quick_start_guide.txt
For some reason, for me if I select “flash OS” then after the flashing operation it won’t boot properly, but now it’s okay, I can install Jetpack by deselecting “Flash OS” as part of the setup.

For the monitor issue, it’s actually much worse than just waiting 5 seconds. Here’s another post that describes what I am experiencing:
https://devtalk.nvidia.com/default/topic/747574/jetson-tk1-boot-issue/

Essentially every time it’s reboot, you have to just keep restarting it, restarting the monitor, and plugging in/unplugging the HDMI cable until everything comes up correctly. Waiting doesn’t seem to help, I can leave it for 5 minutes and still no video.

So thanks for the help, the original problem posted about here is resolved, but the video thing is still kind of annoying