JetPack install softwares to TX2 failed

Host: ubuntu16.04
Device: TX2
JetPack: 3.3

  1. Flashing OS is ok
  2. Host(ubuntu16.04) ssh to TX2 is ok
  3. Error provide nothing!

Error picture: [http://chuantu.xyz/t6/702/1557968094x1033347913.png ]

Hi jeaseng,

Are you got this error every time?
Please try to unplug LAN cable and plug-in again to check the issue still exist or not.
If still get the same error, please provide the logs for check. Thanks!
Logs link: ~/JetPack-3.3/_installer/logs/

Thanks for your reply ! but unplug and plug LAN cable is no use.
there are many log files in ~/JetPack-3.3/_installer/logs/ , how can i send it to you ?

test.png

Hi jeaseng,

Please attached “jetpack_debug.log” this one. Thanks!


jetpack_debug.log (86.8 KB)

Hi jeaseng,

Can you please try below steps and provide more information?

  1. When the issue occurs, keep the JetPack window open.
  2. Open a terminal window, run “/home/shining3d/downloads/jetpack_3.3_packages/_installer/PageAction jetpack_device_info set_info <target_ip_address> <target_username> <target_password>” command in it. Please replace the “<target_ip_address>”, “<target_username>”, and “<target_password>” with actual ip address, username, and password for TX2.
  3. Then paste the command line output of step 2.

Hi jeaseng,

Can you please install sshpass with “sudo apt-get install sshpass” command then retry?

Unable to install sshpass on my Ubuntu16.04, and I’m still trying to install

(1)sudo apt-get install sshpass
正在读取软件包列表… 完成
正在分析软件包的依赖关系树
正在读取状态信息… 完成
E: 无法定位软件包 sshpass

(2) install from source code, and ./configure is ok
make -j12 CDPATH="{ZSH_VERSION+.}:" && cd . && /bin/bash /home/user/downloads/sshpass/missing aclocal-1.15
/home/user/downloads/sshpass/missing: 行 81: aclocal-1.15: 未找到命令
WARNING: ‘aclocal-1.15’ is missing on your system.
You should only need it if you modified ‘acinclude.m4’ or
‘configure.ac’ or m4 files included by ‘configure.ac’.
The ‘aclocal’ program is part of the GNU Automake package:
http://www.gnu.org/software/automake
It also requires GNU Autoconf, GNU m4 and Perl in order to run:
http://www.gnu.org/software/autoconf
http://www.gnu.org/software/m4/
http://www.perl.org/
Makefile:342: recipe for target ‘aclocal.m4’ failed
make: *** [aclocal.m4] Error 127

What is the result of “sudo apt-get update; echo $?” command? Is there any error in it?

Sorry for taking so long to reply,I get nothing after typing in “sudo apt-get update; echo $?” , feeling is a problem caused by Ubuntu system,so I reinstall ubuntu16.04,and everything is all right(apt-get install sshpass is ok too)